On Nov 9, 2007 4:34 PM, Philipp von Weitershausen
> Those are exactly the problems with the locked down index:
> * You can always use *more* packages but you'll have to lock them down
> yourself, can't use another KGS for those

Could we create a grok KGS which is generated by a python-script, that
takes the correct zope3 KGS as a base?

> * You cannot say "I know the KGS prefers zope.frobnaz 1.2.3, but I
> deliberately want to upgrade to zope.frobnaz 2.0.2". It won't work
> because the index simply doesn't expose the 2.0.2 version of zope.frobnaz.

This needs to be fixed in setup tools some time in the future, then,
because it will severly limit the usablility of a KGSs if you can't
use this.  You very often need to upgrade one package...

Lennart Regebro: Zope and Plone consulting.
+33 661 58 14 64
Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to