Hi all,

For fun, I just tried to make use of adapters and utilities, registered with ZCML, in a Pylons application.


I installed Pylons in a virtualenv, and easy_installed zope.component and zope.interface using the KGS index for 3.4. I used zope.configuration (also installed) to load a site.zcml, which currently just has:

        <configure xmlns="http://namespaces.zope.org/zope";>
                <include package="zope.component" file="meta.zcml" />
        </configure>

That doesn't work - it complains about not finding zope.security.zcml.

Then I tried to easy_install zope.security, but this pulled in most of Zope, including the ZODB, ZConfig and zdaemon. That's a real shame - no CA (at least not with ZCML) without having pretty much all of Zope there. :(

Actually, I never got to try it further, because this then died with:

Installed /Users/optilude/Development/Pylons/zylons/lib/python2.4/site-packages/ZConfig-2.5-py2.4.egg error: Installed distribution zope.traversing 3.4.0 conflicts with requirement zope.traversing>=3.5.0a1.dev-r78730

Are the Zope eggs ready for prime time? Maybe I should be doing it differently?

I'm curious about how to go about this, since it seems like an incredibly useful thing to be able to do: Make use of the CA in a non-Zope Python application. :)

Help appreciated!

Martin

--
Author of `Professional Plone Development`, a book for developers who
want to work with Plone. See http://martinaspeli.net/plone-book

_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to