On Thu, Dec 3, 2009 at 5:27 AM, Shane Hathaway <sh...@hathawaymix.org> wrote:
> To me, "myobj.get(x)" reads as "myobj, please get x and give me the
> result", so "IFoo.adapt(y)" reads as "IFoo, please adapt y and give me
> the result". That statement makes perfect sense to me.
Agreed. I also like "adapt" because it is a verb -- which I prefer
method names to be. For the same reason I'm not real keen on the name
"utility"... although I can't come up with anything better than
"get_utility" at the moment.
Too bad less-than is already defined for interfaces, otherwise we could
do something crazy like IFoo<context> for single adapters and
IFoo<a, b, c> for multiapdapters.
I suppose we could do: IFoo<<context>> and IFoo<<a, b, c>> instead.
Somehow I suspect that'll provoke a gag reflex in the most Pythonic
among us as well as annoy those that want something "googlable" for the
uninformed code reader.
Zope-Dev maillist - Zope-Dev@zope.org
** No cross posts or HTML encoding! **
(Related lists -