Am 03.12.2009, 14:18 Uhr, schrieb Benji York <>:

> Agreed.  I also like "adapt" because it is a verb -- which I prefer
> method names to be.  For the same reason I'm not real keen on the name
> "utility"... although I can't come up with anything better than
> "get_utility" at the moment.

I've been struggling with this as well. I think the linguistic quandary is  
similar to the adapter/utility (non-)unification stuff. There is great  
value in saying that method names *should* be verbs. Alternatives might be  
IFoo.return() (is this doable?) IFoo.issue() (like library books), or  
IFoo.use() (because I can't bring myself to use "utilise") However, there  
is probably more value in consistency with the terms as used in the API.

It's been a very interesting discussion for me as I don't spend that much  
time coding. Regarding introducing non-zopers to this stuff: I've found  
that both Philip von Weiterhausen and Martin Aspeli do make this stuff  
easier to understand assuming you've got some kind of application context.  
But we do need to evangelise this stuff better!

@Chris - Are you referring to the interface specification/marker duality?  
If so, I agree that this is definitely a conceptual pothole and most of  
the use I've seen is of interfaces as markers (smartcards).

Charlie Clark
Managing Director
Clark Consulting & Research
German Office
Helmholtzstr. 20
D- 40215
Tel: +49-211-600-3657
Mobile: +49-178-782-6226
Zope-Dev maillist  -
**  No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to