Am Dienstag 05 Januar 2010 16:12:02 schrieb Lennart Regebro:
> On Tue, Jan 5, 2010 at 16:10, Hermann Himmelbauer <> wrote:
> > Hmmm. Bad luck for me.
> It would be interesting to know why you have to use Python 2.4.

My application relies on the MaxDB database (former SAP-DB). They offer a 
Python module which can only be imported with Python <= 2.4.

I still hope that SAP releases a newer Python module, although they don't seem 
to do so soon. So the remaining alternative is to develop a DBAPI 2.0 
compliant Python/MaxDB module by myself, which is, however, quite some work.

Another alternative would be to switch over to PostgreSQL, but this is not yet 

Btw., if you are interested, you can see the application here (an online 
banking for training firms):

Best Regards,

GPG key ID: 299893C7 (on keyservers)
FP: 0124 2584 8809 EF2A DBF9  4902 64B4 D16B 2998 93C7
Zope-Dev maillist  -
**  No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to