Christian Theune wrote:
see subject. What's the reason that all three flavours (still?) exist? I
just had a really hard time finding the spelling I need.
ztapi.provideUtility(interface, component) is discouraged and should go
away. I didn't do this for Zope 3.3 because of a lack of time.
zope.component.provideUtility(component, interface=optional) is a
convenience spelling for:
The order of arguments is the same. I think Jim wants the convenience
functions in zope.component (provide*) to go away in favor of the
explicit spelling through the global site manager. I think that before
we do that, we should first abolish the term "site manager" from the
zope.component API (because we don't call it site manager anymore).
Zope3-dev mailing list