Malthe Borch wrote:


What is going wrong here? I'm running an OpenBSD-system with the latest Python 2.3.5 and 512 MB of RAM. The stack size is 0x100000, as opposed to 0x20000 that previous *BSD-distributions of Python had as default.

What architecture are you running OpenBSD on? We have been running Zope on OpenBSD/AMD64 3.6 for about a year now and it works pretty well. I have however recently discovered a python bug that I am trying to track down. I am unsure of the exact problem, but it affects the re and string libs:

zeo1# uname -a
OpenBSD 3.6 conf#0 amd64
zeo1# python
Python 2.3.4 (#1, Nov 16 2004, 08:26:06)
[GCC 3.3.2 (propolice)] on openbsd3
Type "help", "copyright", "credits" or "license" for more information.
>>> import string
>>> string.whitespace
'\t\n\x0b\x0c\r \x89\x8a\x8b\x8c\x8d\xa0'

on all other platforms I've tried string.whitespace stops after '\r'... the trailing chars cause problems in weird and wonderful places. I upgraded to python 2.3.5 and get the same result. Not tried on python 2.4 yet.

Other than that, we've not had any memory issues. On OpenBSD a single process cannot grow over 1GB of process memory (it can get more than that via anon-mmap, but python doesn't support that). On OpenBSD 3.5 we notice that if we hit the 1GB barrier hard it would panic the kernel, but that was fixed in 3.6.

How much memory is python using when you get the memory errors? Has it truely used up all the memory on the system? There are soft limits that are set via login.conf and ulimit/limits which may be too low for you.


Matt Hamilton                                       [EMAIL PROTECTED]
Netsight Internet Solutions, Ltd.        Business Vision on the Internet                             +44 (0)117 9090901
Web Design | Zope/Plone Development & Consulting | Co-location | Hosting
Zope maillist  -
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to