On Sun, Nov 16, 2008 at 11:36 PM, Brendan Eich <[EMAIL PROTECTED]> wrote: > On Nov 16, 2008, at 7:32 PM, David-Sarah Hopwood wrote: > >> The references to [[Get]] and [[ThrowablePut]] are needed because it is > > Anyone else find ThrowablePut misnamed?
I thought it was confusing. > Total nit, but ThrowingPut would be > better. Or FalliblePut, or to be long-winded, PutCapableOfThrowing but not > ThrowablePut (the Put is not the object thrown, an exception is). Any of these are better. ThrowingPut indicates what happens when failure occurs and I think that is good if throwing is always what happens when failure occurs. FailablePut doesn't make such indication. Peter _______________________________________________ Es-discuss mailing list [email protected] https://mail.mozilla.org/listinfo/es-discuss

