I can understand about not being able to compile due to missing jars from other 
sources if their license says they can't be included in this download.  That's 
not a problem as long as I can find them.  Though I still can't find a jar to 
fix the javax.media.jai references, I'm more concerned with the missing 
org.apache.fop.fonts classes.  Please tell me more about this "built on the 
fly".  After getting all the files into a folder using the svn checkout 
command, I went into Eclipse and selected File > New > Java Project, then 
"Create project from existing source" and just selected that folder.  Selecting 
Next and Finish, leaving any options as default, I then tried the Build 
Project.  How would I set up the special build requirements to make the "on the 
fly" classes?

-----Original Message-----
From: Georg Datterl [mailto:georg.datt...@geneon.de] 
Sent: Thursday, May 27, 2010 9:44 AM
To: fop-dev@xmlgraphics.apache.org
Subject: AW: FOP Trunk

Hi Eric,

Some classes are built on the fly during the ant build process. A simple 
compile of the existing classes in Eclipse can't find them. Some external jars 
are missing because of licensing constraints, AFAIK.


Georg Datterl

------ Kontakt ------

Georg Datterl

Geneon media solutions gmbh
Gutenstetter Straße 8a
90449 Nürnberg

HRB Nürnberg: 17193
Geschäftsführer: Yong-Harry Steiert

Tel.: 0911/36 78 88 - 26
Fax: 0911/36 78 88 - 20


Weitere Mitglieder der Willmy MediaGroup:

IRS Integrated Realization Services GmbH:    www.irs-nbg.de
Willmy PrintMedia GmbH:                            www.willmy.de
Willmy Consult & Content GmbH:                 www.willmycc.de

-----Ursprüngliche Nachricht-----
Von: Venkat Reddy [mailto:vanukuri.ven...@googlemail.com]
Gesendet: Donnerstag, 27. Mai 2010 15:40
An: fop-dev@xmlgraphics.apache.org
Betreff: Re: FOP Trunk

Hi Eric,

It is working for me, just downloaded the FOPTrunk source code. I am able to 
run compile ant target successfully, and the classes were generated in build 
I am in windows environment, don't have an idea why you were unable to compile 
the project....?


Eric Douglas wrote:
> Hi,
> I downloaded the FOP Trunk using the svn checkout, then tried to 
> create a project and import it into Eclipse and compile it, and got 
> all sorts of errors.  Am I missing something?
> First it said it was missing classes.  I selected edit build path and 
> added external jars ant.jar and junit-4.8.2.jar I found and downloaded 
> seperately.  That fixed a lot of the errors.  It's still saying it 
> can't find classes from javax.media.jai.*, 
> org.apache.fop.fonts.base14.*, and 
> org.apache.fop.fonts.CodePointMapping, and it lists errors in XML 
> files and the properties.dtd file (which starts a <!DOCTYPE tag and 
> never closes it).

Reply via email to