Hi David,

David C. Kerber schrieb:
> What version of Net.exe are you using?  The one from the client 3.0?  I 
> believe I'm using the one from the WG1049 (dos server) package I asked you 
> about last week, so I'll see if changing it helps.

I also use the NET.EXE from WG1049, which is dated from 06.06.94

I have three versions here:
- one from the msclient 3.0 disk 1, dated from 07.02.95, which has no 
server functions
- one from the nnet.exe update, dated from 06.03.1995, including 
server functions.
- one from WG1049, 06.06.94 including server functions.

As you use the FreeDOS machine only as client, you might want to try 
the original ms client version.

Did you do any changes to the XP side? Did you turn the firewall off 
for testing?

I post my PROTOCOL.INI and SYSTEM.INI from MS CLIENT's NET directory 
and my system files, maybe you want to compare the settings.

BTW: I just noticed: Copying files from and to a mapped XP drive works 
well on the command line. But if I use DOS navigator (V.1.51) to copy 
a file "test.txt" from c:\ on my freedos machine to the mapped drive 
I:\ of the XP machine DN asks: "File I:\test.txt already exists in 
destination directory" and I can choose to Overwrite / Append/ Rename/ 
Skip/ Cancel. Overwriting does the trick. But this happens with every 
attempt to copy any file. So it depends from the application too.

regards
Uli

___________________________________________________________________
PROTOCOL.INI

[network.setup]
version=0x3110
netcard=PC_CARD,1,PC_CARD,1
transport=tcpip,TCPIP
lana0=PC_CARD,1,tcpip

[protman]
DriverName=PROTMAN$
PRIORITY=MS$NDISHLP

[PC_CARD]
DriverName=DFE670$

[MS$NDISHLP]
DriverName=ndishlp$
BINDINGS=PC_CARD

[MS$NETBEUI]
DriverName=netbeui$
SESSIONS=10
NCBS=12
BINDINGS=PC_CARD
LANABASE=0

[MS$NWLINK]
FRAME=ETHERNET_802.2
DriverName=nwlink$
BINDINGS=PC_CARD

[PKTDRV]
drivername=PKTDRV$
bindings=PC_CARD
intvec=0x60
chainvec=0x66

[TCPIP]
NBSessions=6
DefaultGateway0=192 168 1 1
SubNetMask0=255 255 255 0
IPAddress0=192 168 1 80
DisableDHCP=1
DriverName=TCPIP$
BINDINGS=PC_CARD
LANABASE=0


___________________________________________________________________
SYSTEM.INI

[network]
sizworkbuf=1498
filesharing=yes
printsharing=yes
autologon=no
computername=freedos
lanroot=C:\NETWORK\NET
username=freedos
workgroup=CHAOS
reconnect=no
dospophotkey=N
lmlogon=0
logondomain=CHAOS
preferredredir=full
autostart=basic
maxconnections=8

[network drivers]
netcard=DFE670.DOS
transport=tcpdrv.dos,nemm.dos,dis_pkt9.dos

devdir=C:\NETWORK\NET
LoadRMDrivers=yes

[Password Lists]
*Shares=C:\NETWORK\NET\Shares.PWL
FREEDOS=C:\NETWORK\NET\FREEDOS.PWL

[386enh]
TimerCriticalSection=5000
UniqueDosPSP=TRUE
PSPIncrement=2


___________________________________________________________________
And the relevant sections from AUTOEXEC.BAT

@echo off

SET dosdir=C:\FDOS
set PATH=%dosdir%\bin
SET PATH=%PATH%;C:\CPQDOS;C:\UTIL;C:\NETWORK;C:\NETWORK\PCMCIA;
set NLSPATH=%dosdir%\NLS
set HELPPATH=%dosdir%\HELP
set temp=%dosdir%\temp
set tmp=%dosdir%\temp
set emu387=C:\UTIL\WMEMU387.DXE

SET PATH=%PATH%;C:\NETWORK\NET;

REM Initialize the net first for MS TCP/IP:
C:\NETWORK\NET\net initialize
REM Further TCP/IP drivers will be started below


LH DISPLAY CON=(EGA,,1)
MODE CON CP PREP=((858) C:\FDOS\cpi\EGA.CPX)
LH MODE CON CP SEL=858
LH C:\FDOS\BIN\SHARE.COM /L:500 /F:2048 /L:20

LH C:\FDOS\BIN\CWSDPMI.EXE -R

SET autofile=C:\autoexec.bat
alias reboot=fdapm warmboot
alias halt=fdapm poweroff
alias suspend=fdapm suspend
SET CFGFILE=C:\fdconfig.sys
LH KEYB GR,,keyboard.sys
mouse

REM Activate also those drivers for MS TCP/IP----------
C:\NETWORK\NET\netbind.com
LH C:\NETWORK\NET\umb.com
C:\NETWORK\NET\tcptsr.exe
C:\NETWORK\NET\tinyrfc.exe
LH C:\NETWORK\NET\nmtsr.exe
C:\NETWORK\NET\emsbfr.exe
LH C:\NETWORK\NET\net start

goto end

:END


___________________________________________________________________
And the relevant sections from FDCONFIG.SYS


COUNTRY=001,858,C:\FDOS\BIN\COUNTRY.SYS
SET lang=DE
LASTDRIVE=Z
FILES=40
BUFFERS=25
DOS=HIGH,UMB
DOSDATA=UMB

set dircmd=/ogn /4

; Memory management
DEVICE=C:\FDOS\BIN\JEMMEX.EXE ALTBOOT NOEMS X=D000-D7FF NOVME NOINVLPG

; Other Settings
; --------------------------------
VERSION=6.22
STACKS=0,0

; Enable PCMCIA:
; --------------------------------

DEVICEHIGH=C:\NETWORK\PCMCIA\SSVLSI.EXE
DEVICEHIGH=C:\NETWORK\PCMCIA\CS.EXE
DEVICE=C:\NETWORK\PCMCIA\CSALLOC.EXE

; This is needed for MS Client 3.0
DEVICE=C:\NETWORK\NET\IFSHLP.SYS

; Load Autoexec.bat
; --------------------------------
SHELL=C:\FDOS\bin\command.com C:\FDOS\bin /E:2048 /P=C:\autoexec.bat



-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Freedos-user mailing list
Freedos-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/freedos-user

Reply via email to