Thank you Dannon for looking into this.  

No there was nothing special about this installation.  I installed it on CentOS 
and I tried to follow instructions in installing and configuring tools and 
data.  The only thing that I did not was to test this feature before I 
integrate it with postgres, nginx, tools such as bwa, samtools, bowtie etc.  I 
might have done something not right while doing so.  But once I was done with 
all the configuration steps, I tried to load files via "Get Data" or "Data 
Library".  It kept spinning and nothing is actually being written to the 
system.  I tailed the logs and it was writing some logs every seconds but no 
errors or warnings.  

The issue was resolved when I used "URL/Text" to go to this link as another 
trail test.  After that everything works just fine.  Now we can load files via 
either way.

The only error I keep seeing in the log is when we restart the server and from 
what I read, this is a bug...

Traceback (most recent call last):
  File "/Users/dtenenba/dev/galaxy-dist/lib/galaxy/jobs/",
line 447, in _load_plugin
    module = __import__( module_name )
  File "/Users/dtenenba/dev/galaxy-dist/lib/galaxy/jobs/runners/",
line 232
    worker = threading.Thread( ( name="LwrJobRunner.thread-%d" % i ), 
target=self.run_next )
SyntaxError: invalid syntax


Please let me know if you want me to do anything else that might help debugging 
this issue.


-----Original Message-----
From: Dannon Baker [] 
Sent: Sunday, February 03, 2013 7:14 PM
To: Hakeem Almabrazi
Cc: Stephen Groenewold; Galaxy Dev; Bugs
Subject: Re: [galaxy-dev] File Upload doesn't generate any activity

I just wanted to follow up on this and make sure everything was now working as 
expected.  I've tried to reproduce the original issue and have thus far been 
unsuccessful in doing so with a fresh instance.  Is the configuration of your 
Galaxy instance special in any way?  Did you notice any logged errors (either 
in the Javascript console or in Galaxy's log)?


On Feb 1, 2013, at 3:37 PM, Hakeem Almabrazi <> wrote:

> Stephen,,,
> Here is your solution:
> In the Tools panel select "Get Data", "Upload File". You can either upload a 
> file, or enter one or more URLs in the "URL/Text" box. Enter 
> ""; in the box and click "Execute"
> I am not sure what happened there but it seems this triggered some database 
> updates that was needed. 
> It worked J....
> From: 
> [] On Behalf Of Stephen Groenewold
> Sent: Friday, February 01, 2013 10:41 AM
> To:
> Subject: [galaxy-dev] File Upload doesn't generate any activity
> We've  installed a local instance of Galaxy and are having trouble with the 
> first step of uploading files. The only thing that will currently upload is 
> text pasted into the URL/Text box.
> Any attempt to upload a file using the Browse File box not only fails, it 
> never even starts. It's as if the Execute button is disabled.
> I've tried changing the ajax-upload parameter to "false" in 
> tools/data_source/upload.xml (as mentioned in a workaround posted to the list 
> by Daniel Blankenburg in Aug 2012). I've also tried using different browsers 
> (including Internet Explorer) and going the route of Adding Data Libraries as 
> Admin. None of those attempts have worked.
> Am I missing a configuration setup? Could there be permissions issues on the 
> Galaxy machine?
> Thanks.
> Steve
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:

Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

Reply via email to