> On Feb 23, 2015, at 8:23 AM, Saket Choudhary <sake...@gmail.com> wrote:
> 
> On 22 February 2015 at 23:17, Michael Thon <mike.t...@gmail.com> wrote:
>> bam_index_build2() not yet
> 
> Hi Michael,
> 
> This seems to be related to this:
> https://github.com/samtools/samtools/issues/199
> 
> You should probably switch to samtools 0.1.19
> 
> Saket


I figured that galaxy must be finding a samtools v1.1 even though the tool was 
not installed, according to the admin page. I uninstalled the samtools that was 
installed system-wide on the server.  Now I get this error:
Traceback (most recent call last):
  File "/home/galaxy/galaxy-dist/lib/galaxy/jobs/runners/local.py", line 129, 
in queue_job
    job_wrapper.finish( stdout, stderr, exit_code )
  File "/home/galaxy/galaxy-dist/lib/galaxy/jobs/__init__.py", line 1107, in 
finish
    dataset.datatype.set_meta( dataset, overwrite=False )  # call 
datatype.set_meta directly for the initial set_meta call during dataset creation
  File "/home/galaxy/galaxy-dist/lib/galaxy/datatypes/binary.py", line 250, in 
set_meta
    raise Exception, "Error Setting BAM Metadata: %s" % stderr
Exception: Error Setting BAM Metadata: /bin/sh: 1: samtools: not found
So, galaxy is not using the samtools from the installed galaxy package and is 
instead using the system one.  I'll try to reinstall samtools and see if that 
fixes it...



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to