On Tue, Feb 24, 2015 at 6:31 AM, Michael Thon <mike.t...@gmail.com> wrote:
> The main problem for me was that I was not aware that the tophat
> tool had a dependency on a command line tool outside of galaxy
> installation.  I see in the admin interface that tophat has a dependency
> on samtools of type package and I assumed that should provide the
> samtools binary.  Of course I have not read the manuals regarding
> tool sheds, dependencies, etc so thats probably where my problem
> started in the first place...

I can see your chain of thought here. Unfortunately while the tophat
tool (or any tool) may explicitly use samtools (and request a particular
version via the dependencies system), once the tool has finished it
has produced a BAM file. So far so good, but at that point Galaxy
tries to index the BAM file itself. This happens for any BAM file,
regardless of the tool which created it - and simply expects samtools
on the $PATH.

If this is on the wiki (core dependencies of Galaxy itself), could
someone post the URL here please?

Peter
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to