"Hal V. Engel" <[EMAIL PROTECTED]> writes:

> I have also tried installing GTK 2.4 on SuSE 9.1 without success.  I
> have not tried 2.6 yet.  SuSE 9.1 comes with GTK 2.2.4.  Many things
> stop working when GTK 2.4 is installed and it appears that many
> applications would need to be rebuilt to get things working again.

You are doing something wrong then. The GTK+-2.x series provides
binary backward compatibility. Applications compiled against older
versions of glib/pango/gtk+ will continue to work after an upgrade.
There's no need to recompile anything. And this is not just a myth,
it definitely works. I am running a GNOME desktop where almost
everything was built against gtk+-2.4.x. As promised, upgrading to
gtk+-2.6 didn't introduce any problems whatsoever.

Gimp-developer mailing list

Reply via email to