On Tue, 2009-07-14 at 22:50 +0200, Martin Nordholts wrote:
> On 07/14/2009 10:44 PM, Sven Neumann wrote:
> >> This function creates a new dialog, and plug-ins then use
> >> GtkWidget * gimp_export_dialog_get_container (GtkWidget *dialog);
> >> to get a vbox that the file-format specific widgets with export options
> >> are put it.
> > I'd suggest to have gimp_export_dialog_add() instead with semantics
> > similar to gtk_container_add().
> That's a good idea, I'll change that.
I don't think it's such a good idea. What about the difference
between gtk_container_add() and gtk_box_pack_start()/end() with
all their options. We should not restrict the ways plugins are
able to construct their GUI, at least definitely not in a way
that forces them to pack everything either expanding of shrinking.
gimp_export_dialog_get_container() was not such a bad idea imho,
but I would call it gimp_export_dialog_get_content_area(), because
we have precedence of this API in GtkDialog.
Also, it should probably return a completely empty vbox,
not the same vbox where the export options got packed into.
Gimp-developer mailing list