On Wed, 2009-07-15 at 15:24 +0200, Michael Natterer wrote:

> I don't think it's such a good idea. What about the difference
> between gtk_container_add() and gtk_box_pack_start()/end() with
> all their options. We should not restrict the ways plugins are
> able to construct their GUI, at least definitely not in a way
> that forces them to pack everything either expanding of shrinking.

That could easily be achieved by packing a vbox into the export dialog
container. But still I like your proposal better.

> gimp_export_dialog_get_container() was not such a bad idea imho,
> but I would call it gimp_export_dialog_get_content_area(), because
> we have precedence of this API in GtkDialog.

+1 from me


Gimp-developer mailing list

Reply via email to