On Wed, Aug 12, 2009 at 9:45 PM, Andre
Poenitz<andre.poen...@mathematik.tu-chemnitz.de> wrote:
> On Wed, Aug 12, 2009 at 09:15:17PM +0200, zweetsmoel wrote:
>> On Wed, Aug 12, 2009 at 8:40 PM, Andre
>> Poenitz<andre.poen...@mathematik.tu-chemnitz.de> wrote:
>> > On Wed, Aug 12, 2009 at 08:21:00PM +0200, zweetsmoel wrote:
>> >> Hello,
>> >>
>> >> it always happens when you need the bloody thing ;-)
>> >>
>> >> i urgently need to edit and render my CV with lyx. unfortunately lyx
>> >> gives the following error when starting:  symbol lookup error:
>> >> src/lyx: undefined symbol: _Z13qFlagLocationPKc
>> >>
>> >> i tried re-installing lyx 1.6.2, re-installing Qt, i even build 1.6.3
>> >> from source,... but nothing helps :\  googling did not save my day, so
>> >> i'm asking here, because i'm stuck. please.... any suggestions? my
>> >> guess this is Qt related, but i have not a single clue how to fix that
>> >>
>> >> running on ubuntu 9.04, with qt 4.5 (i think)
>> >
>> > The LyX your are trying to start wants to use an older version of Qt
>> > than the one that was used when LyX was compiled.
>> >
>> > This may e.g. happen when you use a self-compiled recent version of Qt
>> > to build LyX and on startup it picks up the older system version.
>> > Setting LD_LIBRARY_PATH apropriately helps in those cases.
>> >
>> > Andre'
>>
>>
>> i've build 1.6.1, but exactly the same error :\ ...
>>
>> andre, thx for the suggestions, but i did not compile Qt myself. it's
>> the standard ubuntu qt libs.
>
> I am reasonably sure that the scenario you describe cannot occur
> with only a single version of Qt on your system.
>
> If you only used only packages form your distribution the only
> explanation I have is that the development package you use (i.e.
> libqt4-dev) does not match the installed libraries. Either there's
> a difference in version of both, or you use the development package
> with a set of defines that's incompatible with the the installed
> version.
>
> The latter seems actually be rather likely as qFlagLocation is
> only used if QT_NO_DEBUG is _not_ set, i.e. you use the Qt in
> "debug" mode. The system Qt is most likely not in debug mode.
>
> If this is the reason you need to make sure that QT_NO_DEBUG is
> defined when you compile LyX. I have no idea how Ubuntu packages
> the Qt development package, but I guess configuring LyX with
> "CXXFLAGS=-DQT_NO_DEBUG ./configure" or similar might help.
>
> Andre'
>
> PS:
>
>> could you please elaborate on how to use 'setting LD_LIBRARY_PATH'?
>> i'm not sure that i understand what you mean.
>
> That's only relevant for the case where you have multiple versions
> of Qt on your system, so let's ignore this for now.
>

only another error message...
src/lyx: symbol lookup error: src/lyx: undefined symbol:
_ZN8QPainter10drawPixmapERK7QPointFRK7QPixmap

ok, this is definitely a qt error. even qtconfig won't launch, it
gotta be qt related. but what exactly? i tried removing &
re-installing all qt packages and many others; and i wasn't able to
find duplicate qt libs, but i'm not really an expert in libs and devs.

too bad, that's gonna be a CV made with ms-office. yak... ;-)

thanks for the feedback folks
michael

Reply via email to