On 12/01/2010 08:00 AM, Birte Schoettker wrote:
Hi all,

I run Lyx under Windows and use Jabref 2.6 to create my *.bib file for the references I use in Lyx via Insert>List/TOC>BiBTex Bibliography'. That all worked fine so far for the last 2 years, gaining insights about coding in jabref and dabandoning endnote for good on this way so far.

What confuses me these days, is that I cannot recall to have changed anything relevant from last week to this in my *.bib reference file. I might have added about 10 more references or deleted a couple. However, the last times I tried to use my added bibliography in Lyx via "Insert> Citation" it has been missing all entries in my *.bib file or jabref library alphabetically onwards from Wi*** to Z. The number of my references in my library is 1898 (!). Is there a cut-off I am not aware off?

No, there's no cutoff. What's probably happening is that you have an illegal character in one of your entries, probably the first one that doesn't appear, and LyX is aborting the read when it sees it. This is a pretty common problem. It often happens when people cut and paste material from the web into JabRef and they get a funny quote or something in there. If you can manage to launch LyX from a terminal, then you will probably see the error message, which may also help. If not, you can send me the file privately, and I'll figure it out.

Information that might be important:
- coding of my library: Cp1252

I don't know if that is an issue or not, but, ideally, BibTeX files should always be pure ASCII. If you need non-ASCII characters, then use the LaTeX equivalent.


Reply via email to