> On Sep 22, 2016, at 1:07 PM, Jeremy Huddleston Sequoia 
> <jerem...@macports.org> wrote:
> 
>> 
>> On Sep 22, 2016, at 07:19, Adam Dershowitz <de...@alum.mit.edu> wrote:
>> 
>> 
>> 
>>> On Sep 22, 2016, at 4:49 AM, Jeremy Huddleston Sequoia 
>>> <jerem...@macports.org> wrote:
>>> 
>>> 
>>>> On Sep 21, 2016, at 12:45, Adam Dershowitz <de...@alum.mit.edu> wrote:
>>>> 
>>>> It does:
>>>> 
>>>> $ xcode-select -p
>>>> /Applications/Xcode.app/Contents/Developer
>>>> 
>>>> 
>>>> For me some updates in Macports, including some builds, seem to work OK, 
>>>> and others, such as cmake, are giving an error:
>>>> https://trac.macports.org/ticket/52258
>>>> 
>>>> I’m not sure if I then need to completely switch to Xcode 7?  Or if I can 
>>>> just install the command line tools for 10.11 Xcode 7.3.1?  If I do that, 
>>>> where do they install, so that I can point xcode-select to the proper path?
>>> 
>>> If you don't have the CLTools installed, you wouldn't be able to install 
>>> most of MacPorts.  I'm pretty sure you likely have them installed.
>>> 
>>> Dropping back down to Xcode 7 would mean that Xcode.app would contain the 
>>> 10.11 SDK and would workaround your issue, but the issue is that the port 
>>> isn't honoring your SDK (and maybe deployment target) selections (which 
>>> default to / and host os version respectively).
>>> 
>>> 
>> 
>> 
>> Something is still not clear to me.  I had Xcode 7 installed.  I was under 
>> the impression that it included the SDK internally, so I don’t think that I 
>> had separately installed the CLTools (although I’m not positive).
> 
> Do you have /usr/include on your system?  If you do, you installed the 
> CLTools.

Yes, I do.  Although I can’t confirm when I might have installed it (is there 
an easy way to tell if the headers were from some older version i.e. 10.7,10.8 
etc?).


> 
>> And, I have used macports for many years without a problem (over many 
>> versions of Xcode).  When Xcode 8 was released I installed it, but didn’t 
>> install CLTools either.
>> What still isn’t clear to me is if cmake and openmodelica (which does have 
>> the same problem as cmake, but it also depends on cmake so I tried to build 
>> that with the working cmake) should work with my current configuration?  Do 
>> they each have a bug?  Should just installing 10.11 CLTools allow them to 
>> build?
> 
> It's possibly a bug in cmake and openmodelica ports (they're using the SDK 
> inside of Xcode.app even though MacPorts is configured to use /).
> 
> It's definitely a bug in cmake and openmodelica upstream.  They're failing to 
> build properly for the older deployment targets when using newer SDKs.

In that case, it sounds likely that installing the newer CLTools won’t help, 
since I already have /usr/include.  So, at this point my options are to wait 
for bug fixes, or to downgrade.
> 
>> Perhaps the answer, that I was missing, is that to use Xcode 8, on 10.11, 
>> the user must explicitly install CLTools, but that would not be the case to 
>> run Xcode 7 on 10.11 or Xcode 8 on 10.12?
> 
> Depends on your perspective.  We'd like to be in the world where you don't 
> need to install the system headers, but 90% of OSS software fails when the 
> SDK is newer than the base system because most OSS assumes that the SDK 
> matches the minimum deployment target.



Thanks.

Attachment: signature.asc
Description: Message signed with OpenPGP using GPGMail

_______________________________________________
macports-dev mailing list
macports-dev@lists.macosforge.org
https://lists.macosforge.org/mailman/listinfo/macports-dev

Reply via email to