* Alvaro Herrera (alvhe...@2ndquadrant.com) wrote: > Adam Brightwell wrote: > > I'm not sure there was an actual discussion on the topic. Though, at one > > point I had proposed it as one of the forms of this attribute. Personally, > > I think it is easier to read with the underscore. But, ultimately, I > > defaulted to no underscore to remain consistent with the other attributes, > > such as CREATEDB and CREATEROLE. > > If we were choosing those names nowadays, would we choose CREATEDB at > all in the first place? I think we'd go for something more verbose, > probably CREATE_DATABASE. (CREATEROLE is not as old as CREATEDB, but my > bet is that it was modelled after CREATEUSER without considering the > whole readability topic too much.) > > Anyway it doesn't seem to me that consistency with lack of separators in > those very old names should be our guiding principle here.
So you'd advocate EXCLUSIVE_BACKUP and NOEXCLUSIVE_BACKUP? Or NO_EXCLUSIVE_BACKUP? Or..? If this was a green field, I think we might actually use spaces instead, but I'm really not sure we want to go through and redo everything that way at this point.. We'd end up breaking a lot of scripts that currently work today and I'm really not convinced it's better enough to justify that. Thanks! Stephen
Description: Digital signature