Stephen Frost <> writes:
> * Alvaro Herrera ( wrote:
>> If we were choosing those names nowadays, would we choose CREATEDB at
>> all in the first place?  I think we'd go for something more verbose,
>> probably CREATE_DATABASE.  (CREATEROLE is not as old as CREATEDB, but my
>> bet is that it was modelled after CREATEUSER without considering the
>> whole readability topic too much.)
>> Anyway it doesn't seem to me that consistency with lack of separators in
>> those very old names should be our guiding principle here.

> NO_EXCLUSIVE_BACKUP?  Or..?  If this was a green field, I think we might
> actually use spaces instead, but I'm really not sure we want to go
> through and redo everything that way at this point..  We'd end up
> breaking a lot of scripts that currently work today and I'm really not
> convinced it's better enough to justify that.

FWIW, I agree with Alvaro, and I'd go with e.g. NO_EXCLUSIVE_BACKUP.

I concur that multiple separate words would be a syntax mess, but I
see no reason not to use underscores instead.

                        regards, tom lane

Sent via pgsql-hackers mailing list (
To make changes to your subscription:

Reply via email to