On 2017-01-17 12:52:20 -0500, Tom Lane wrote:
> Robert Haas <robertmh...@gmail.com> writes:
> > On Mon, Jan 16, 2017 at 2:13 PM, Tom Lane <t...@sss.pgh.pa.us> wrote:
> >> "Srf" is ugly as can be, and unintelligible. SetResult might be OK.
> > The operation we're performing here, IIUC, is projection. SetResult
> > lacks a verb, although Set could be confused with one; someone might
> > think this is the node that sets a result, whatever that means.
> > Anyway, I suggest working Project in there somehow. If Project by
> > itself seems like it's too generic, perhaps ProjectSet or
> > ProjectSetResult would be suitable.
I'd not have gone for SetResult if we didn't already have Result. I'm
not super happy ending up having Project in ProjectSet but not in the
Result that end up doing the majority of the projection. But eh, we can
live with it.
> Andres' patch is already using "SetProjectionPath" for the path struct
> type. Maybe make that "ProjectSetPath", giving rise to a "ProjectSet"
> plan node?
> I'm happy to do a global-search-and-replace while I'm reviewing the
> patch, but let's decide on names PDQ.
Yes, let's decide soon please.
Sent via pgsql-hackers mailing list (firstname.lastname@example.org)
To make changes to your subscription: