Hi Thorsten,

> so thats the solution - I have a local installation, I set the 4 links
> to /usr/bin/ and /usr/share/ as described in INSTALL - but apparently
> only /usr/share/picolisp is the one that works.  I have no idea why.

how did you install your local picolisp?  Did you "cd src; make"?  Can
you find the bin/picolisp executable file after that?

> after changing all calls to 'pil' to '/usr/share/picolisp/pil' and the
> call to swank-picolisp to '/usr/share/picolisp/lib/swank-picolisp'
> things worked - more or less.  The connection to slime worked, I get a
> slime-repl with a pil> prompt, and calculations like (+ 3 4 ) work -
> but everything is extremely slow, and after each keystroke I get
> 'wrong number of arguments' errors ...

OK.  Now how exactly did you set up your slime?  I think Henrik had a
similar problem because he was using some slime contribs that
swank-picolisp doesn't support.  If you start with those contribs I sent
in the previous email, it should work.

The problem you are seeing is that when you move your cursor, emacs
talks to picolisp to find information about symbols your cursor points
at, e.g. if you write

   pil> (+ 1 2)

and then place your cursor above +, slime tries to display information
about +.  I use emacs autodoc and in this case, I see that the symbol
plus is a built-in function, its address and arguments.

It is slow for you because something about this autodoc stuff doesn't
work for you.

> but anyway - it works, somehow, finally.  I should become a software-
> and usability-tester, I have what it takes ;)


You could have a look at the inferior-lisp buffer and you'll see some
messages sent forth and back between emacs and picolisp.  It should give
you an idea what the problem is.


UNSUBSCRIBE: mailto:picolisp@software-lab.de?subject=Unsubscribe

Reply via email to