Mark,
        Good on yah fella. Seems that you have gotten to the bottom of a bug that has 
irritated us all for a good many years. I know that I will surely test your premise 
next time I am doing the old cut, paste & pray routine. Have you taken the time to 
report this to Protel yet? Have you tried DXP to see if it is similarly effected? 
Possibly they could fix it in DXP at least for our future peace of mind.
        FYI, have you tested your premise on DXF exports as well? I had tried to 
export in DXF to see if it got around the problems but had no luck. With all of the 
various export/import combinations it is surely a Protel problem since it asks 
similarly in so many apps/formats.

Sincerely,
Brad Velander.

Lead PCB Designer
Norsat International Inc.
Microwave Products
Tel   (604) 292-9089 (direct line)
Fax  (604) 292-9010
email: [EMAIL PROTECTED]
http://www.norsat.com


> -----Original Message-----
> From: Mark HARRISON [mailto:[EMAIL PROTECTED]
> Sent: Monday, February 24, 2003 5:50 PM
> To: '[EMAIL PROTECTED]'
> Subject: [PEDA] Cut and Paste bug from schematics to MS Word
> 
> 
> For years I've experienced problems copying schematics into 
> MS Word and
> other Windows applications.
> The short story is:
>  Watch out when using WMF graphics (such as company logos) in 
> your schematic
> templates!  They can corrupt the cut/paste process.
> 
> The long story:
> Specifically, I had trouble cutting and pasting most 
> schematics from Protel
> 99SE (every version) to virtually any Windows based application (under
> Windows 95 and 2000).
> 
> Typical symptoms were:
>  changing fonts and rotation of text.
>  misaligned overscores on pin names.
>  arcs and lines changing into circles.
>  schematics that preview OK in MS Word but print outside the 
> page margins.
> 
> Copying to intermediate applications such as other MS Office 
> applications,
> Corel Draw, etc didn't help (they just produce different errors).
> 
> In the end I gave up and stapled the circuits printed 
> directly from Protel
> into the back of the MS WORD manual (sacrificing the ability 
> to produce a
> single document with proper page numbers, index and table 
> entries, and the
> ability to produce a nice PDF document containing everything).
> 
> After a lot of experimentation and loss of hair I've finally 
> twigged that
> the schematics would cut and paste OK provided the company 
> logo was missing
> (usually because the logo file was not in the same folder as 
> a new project).
> The logo was a WMF (Windows Meta File) embedded in the 
> schematic template
> that I use for all schematics.  All the troubles went away 
> when I either
> deleted the WMF logo file or converted it to a BMP bitmap 
> format (and then
> saved and updated all the schematics in the project with the 
> new template). 
> 
> Although Protel 99SE could display and print the logo itself, it was
> corrupting the Windows Meta File that was placed on the 
> Windows clipboard
> during cut&paste.
> 
> I'd be interested to hear if anyone knows of a Windows tool 
> that can analyse
> or list the contents of WMF files, as I'm curious to see what 
> was wrong with
> the logo file or Protel's interpretation of it.
> 
> Cheers,
> Mark Harrison,
> The Bionic Ear Institute
> Melbourne, Australia


* * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
* To post a message: mailto:[EMAIL PROTECTED]
*
* To leave this list visit:
* http://www.techservinc.com/protelusers/leave.html
*
* Contact the list manager:
* mailto:[EMAIL PROTECTED]
*
* Forum Guidelines Rules:
* http://www.techservinc.com/protelusers/forumrules.html
*
* Browse or Search previous postings:
* http://www.mail-archive.com/[EMAIL PROTECTED]
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

Reply via email to