-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Mislav Marohnić wrote:
> Optimizing getStyle and setStyle methods would not be premature, but a
> very welcome optimization at this point. But it will not be easy. I tried
> to do it in #6696 and Marius took a different approach in #6705 (w/
> benchmarks!!), Tobie spent days on these two methods, and still they hold
> room for much improvement.
Ouch, I forgot about that ticket. Anyway, I digressed too much in that
ticket, it's history. Better yet, now that Martin raised this issue again,
maybe a #6696 split would be more useful, different tickets for different
issues (a ticket for "getElementsByClassName optimization", one for
"get/setStyle optimization", etc). It would be more comfortable, at least
for me, to watch those issues.

> Any optimization must preserve code readability and beauty (think 
> maintainability) and compactness of the framework.
Nicely said, with one possible amendment: "compactness" as in "code size"?
I'd give that the lowest priority, "execution speed" IMHO is far more
important than "download speed". After all, we're talking about "web
applications", not "web pages" (yeah, I know, I'm a fscked-up evangelist).

> p.s. Marius: about http://gfx.neohub.com/benchmark/t/isin.html ... holy 
> crap, this is damn sweet!! Your benchmark lib is growing? :)
Hehe, it's still one of my favorite "weekend projects", so, yes, it's
growing (from time to time). Anyway, IIRC I kinda froze its core API (as I
feel it's mature enough) and started playing with "helpers" (ergo
"Benchmarker") that should leverage building & deploying "demos".
Benchmarker it's still in its infancy state, but it works :)

BTW, did you see my Benchmark port of Andrew's new$$ test? ;-)
  http://gfx.neohub.com/benchmark/t/domquery.html

cheers
- --
Marius Feraru
-----BEGIN PGP SIGNATURE-----

iD8DBQFF2LYKtZHp/AYZiNkRArFnAJ9B9ufVuDqnNFQDcKb1TkgjobTiLgCgvjKj
JIPxw5CgFG/goEj5ajjzjdA=
=SHPG
-----END PGP SIGNATURE-----

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Prototype: Core" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/prototype-core?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to