*long day, missed the part where I blasted my old keyrings if step 3 fails:
sudo rm -rf /home/user/.local/share/keyrings

I had no saved passwords/keys but it was still an issue somehow, so this 
forced the new first-time keyring password prompt on AppVM reboot that I 
left blank. So apparently libgnome-keyring is a dependency. No idea what 
the Nextcloud forum are referenced with libgnome-keyring0.

On Friday, August 16, 2019 at 4:58:08 PM UTC-4, sourcexorapprentice wrote:
>
> libgnome-keyring, not just gnome-keyring.
>
> Various forums suggest an issue (is there though?) in Fedora where PAM and 
> the gnome keyring do not play nice together and an additional theory that 
> the Fedora keyring is just not making Nextcloud entries due to some bug. 
>
> My current solution:
> 1. Boot your template Fedora VM and then install the gnome keyring:
> dnf install -y libgnome-keyring
> sudo shutdown -h now
> 2. Restart your qubes AppVM and login to your Nextcloud client with your 
> password, restart
> 3. Nextcloud starts and is good to go without password
>
> If 3 fails (did for me), then you may want to blast your keyrings 
> (warning: you're deleting your keyrings, so other saved password...), so in 
> the AppVM just run "sudo dnf -y remove gnome-keyring && sudo dnf -y install 
> gnome-keyring" reboot and enter a null password on boot, then repeat step 2.
>
> I'm still anxious about this because my keyring uses as...NULL password! 
> My understanding is that this is an acceptable risk and has the same logic 
> as the null root password. Someone who is local on the AppVM is going to be 
> able to escalate to root anyway, and therefore will own the keyring so 
> you're pwned anyway so just make the keyring null so it's less annoying. Is 
> this horribly wrong?
>
> Example of suggested solutions:
> https://github.com/nextcloud/desktop/issues/427
>
> On Friday, August 16, 2019 at 4:19:22 PM UTC-4, 799 wrote:
>>
>> Hello,
>>
>> On Fri, 16 Aug 2019 at 11:22, Stefan Leibfarth <ste...@leibfarth.org> 
>> wrote:
>>
>>> [...]
>>> I'd guess it's not directly Qubes related, maybe this problem:
>>>
>>> https://help.nextcloud.com/t/nextcloud-client-asks-for-password-every-time-it-starts/28591/3
>>>
>>
>> I tried nearly everything from this forum post, I also tried to use other 
>> templates fedora-29, fedora-30, still the same problem.
>> I also tried to install gnome-keyring but it doesn't make a difference.
>>
>> Anyelse has a Nextcloud CLIENT (not server) running in Qubes and give me 
>> a hint, why I need to re-enter my credentials after boot and even after the 
>> nextcloud client is not pocking up the sync again.
>>
>> [799]
>>
>>

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/80c109d6-3894-4a69-85b3-265e517db57e%40googlegroups.com.

Reply via email to