Progress, and a new issue:

Turns out my initial issue was a problem with the Perforce environment
variable setup on my server.  As noted in some other posts, the Apache
httpd.conf file needs to have SetEnv calls to set the P4PORT,
P4CLIENT, and P4USER.  I discovered this by adding -d to the post-
review command and looking at the HTML error page and output to my
terminal.  Is there any way to view these error pages in a browser
that makes searching through them a bit easier?

In my case, the actual error was "Can't create a new user - over
license quota.  Try deleting old users with @#3;user -d'.  License
count: 4391 users used of 4391 licensed"

I now get a bit further in the post-review process, but I have a new
problem.  The post-review command finishes successfully now, printing

    Review request #20 posted.


And the review shows up on my reviewboard dashboard.  A number of the
review fields that were blank before are now valid (changelist,
description) and the diff button is now visible (yeah! -- first time
I've seen that).  But, when I look at the diff, the diff is a
Traceback listing with the following error at the top:

[Error 2] The system cannot find the file specified
Traceback (most recent call last):
  File "C:\reviewboard\diffviewer\", line 86, in view_diff
    files = get_diff_files(diffset, None, interdiffset, highlighting)
  File "C:\reviewboard\diffviewer\", line 651, in
  File "C:\reviewboard\diffviewer\", line 567, in
    lambda: get_chunks(filediff.diffset,
  File "c:\reviewboard\djblets\util\", line 55, in
    data = lookup_callable()
  File "C:\reviewboard\diffviewer\", line 570, in <lambda>
  File "C:\reviewboard\diffviewer\", line 338, in
    new = get_patched_file(old, filediff)
  File "C:\reviewboard\diffviewer\", line 254, in
    return patch(filediff.diff, buffer, filediff.dest_file)
  File "C:\reviewboard\diffviewer\", line 105, in patch
  File "c:\Python25\lib\", line 593, in __init__
    errread, errwrite)
  File "c:\Python25\lib\", line 793, in _execute_child
WindowsError: [Error 2] The system cannot find the file specified

On Sep 17, 4:28 pm, Daniel Wexler <[EMAIL PROTECTED]> wrote:
> Searching the old posts, looks like this is probably some sort of
> apache configuration error on my part.  However, I don't see any
> errors in the apache log, but I do see two requests for the post, one
> for /api/json/accounts/login/ (which looks like it succeeds) and
> another for /api/json/reviewrequests/new/ which fails.
> Any suggestions on what might be wrong with my apache server config?
> On Sep 17, 1:51 pm, Daniel Wexler <[EMAIL PROTECTED]> wrote:
> > Almost got everything working, but I'm still having some trouble with
> > post-review.  Looks like the diff is now being created properly and
> > most interactions with the server are ok (it creates a new review),
> > but the files are not uploaded and I get the following error:
> > Unable to accesshttp://maki/api/json/reviewrequests/new/. The host
> > path may be invalid
> > HTTP Error 500: Internal Server Error
> > I've tried creating an "api/json/reviewrequests/new/" directory within
> > the htdocs in my reviewboard directory on the server, and changing the
> > permissions to allow the web server to write to it, but no dice.
> > Looks like this is happening at line
> > If I try to access that directory from another machine, with
> > PythonDebug enabled, I get a Page Not Found error with a bit more info
> > from Django:
> > Using the URLconf defined in djblets.util.rooturl, Django tried these
> > URL patterns, in this order:
> > ^ ^admin/
> > ^ ^media/(?P<path>.*)$
> > ^ ^account/
> > ^ ^api/json/
> > ^ ^r/
> > ^ ^reports/
> > ^ ^dashboard/$
> > ^ ^users/$
> > ^ ^users/(?P<username>[A-Za-z0-9_\-\.]+)/$
> > ^ ^groups/$
> > ^ ^groups/(?P<name>[A-Za-z0-9_-]+)/$
> > ^ ^groups/(?P<name>[A-Za-z0-9_-]+)/members/$
> > ^ ^feeds/rss/(?P<url>.*)/$
> > ^ ^feeds/atom/(?P<url>.*)/$
> > ^ ^account/logout/$
> > ^ ^$
> > ^ ^iphone/
> > The current URL, app/, didn't match any of these.
> > Suggestions?
> > Do I need to add something to my Apache httpd.conf file?  I've even
> > tried creating that path in both the Apache and reviewboard htdocs
> > directories and putting a bogus file there, but Django/Apache are
> > intercepting those requests and printing that special 404 page.
> > I'm tantalizingly close to having everything working (database,
> > apache, mod_perl all good now), I made it through a few post-review
> > issues (getting a diff program in my path, setting my P4PORT &
> > P4CLIENT env vars, changing the repository path on the server,...).  I
> > can feel that I'm close now after two full days of setup!
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at

Reply via email to