Also, and I feel I may be abusing this opportunity to ask a third question:

Is there still a problem I should expect if a single server is hosting 
multiple svn repositories? Or was that just an older version. I"m looking 
for documentation for it, but it's not coming to me easily.

On Tuesday, January 14, 2014 2:40:43 PM UTC-5, Christian Hammond wrote:
>
> Hi Zachary,
>
> It's trying to find a match based on the result of 'svn info'. If it can't 
> find a repository entry on Review Board that has a Path or Mirror Path 
> matching your local checkout, then it'll fail. This is a new tool, and we 
> probably should improve it in this case.
>
> What I'd recommend is creating the file by hand. Just create a 
> .reviewboardrc file containing:
>
> REVIEWBOARD_URL = "http://ReviewBoardServer";
> REPOSITORY = "<repository name>"
>
> Now that said, that's going to fail for you right now. There's currently a 
> bug in RBTools with name-based lookups for Subversion. I'm putting out a 
> 0.5.4 release today though, so that'll soon be taken care of. Let me know 
> if you would like me to rush a build to you (and let me know the Python 
> version) and I'll do so.
>
> Christian
>
> -- 
> Christian Hammond - chi...@chipx86.com <javascript:>
> Review Board - http://www.reviewboard.org
> Beanbag, Inc. - http://www.beanbaginc.com
>
>
> On Tue, Jan 14, 2014 at 11:06 AM, Zachary Gallagher <
> zachary....@remcom.com <javascript:>> wrote:
>
>> I navigate to a subversion checkout. I run rbt setup-repo --debug. This 
>> is what I get.
>>
>> There are four repositories linked on our reviewboard server, but they're 
>> not hosted on the same machine. How do I get this to work? I'm sure it's 
>> something blatant that I've missed.
>>
>>
>> [root@*workstation **checkout*]# rbt setup-repo --debug
>> Enter the Review Board server URL: http://*ReviewBoardServer*
>> DEBUG:root:Checking for a Subversion repository...
>> DEBUG:root:Running: svn info --non-interactive
>> DEBUG:root:Running: diff --version
>> DEBUG:root:repository info: Path: https://*SvnServer*/svnrepo, Base 
>> path: /*Base*/*path*/*repository*, Supports changesets: False
>> DEBUG:root:Making HTTP GET request to http://*ReviewBoardServer.Domain.com 
>> <http://ReviewBoardServer.Domain.com>*/api/
>> DEBUG:root:Making HTTP GET request to http://*ReviewBoardServer.Domain.com 
>> <http://ReviewBoardServer.Domain.com>*/api/info/
>> DEBUG:root:Making HTTP GET request to http://*ReviewBoardServer.Domain.com 
>> <http://ReviewBoardServer.Domain.com>*/api/repositories/
>> No Subversion repository found or selected for 
>> http://*ReviewBoardServer.Domain.com 
>> <http://ReviewBoardServer.Domain.com>*/. .reviewboardrc not created.
>>
>>  -- 
>> Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
>> ---
>> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
>> ---
>> Happy user? Let us know at http://www.reviewboard.org/users/
>> --- 
>> You received this message because you are subscribed to the Google Groups 
>> "reviewboard" group.
>> To unsubscribe from this group and stop receiving emails from it, send an 
>> email to reviewboard...@googlegroups.com <javascript:>.
>> For more options, visit https://groups.google.com/groups/opt_out.
>>
>
>

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to