Andrew Wong has posted comments on this change. ( http://gerrit.cloudera.org:8080/8395 )
Change subject: error_manager: synchronize/serialize handling ...................................................................... Patch Set 5: (1 comment) http://gerrit.cloudera.org:8080/#/c/8395/4/src/kudu/fs/error_manager.h File src/kudu/fs/error_manager.h: http://gerrit.cloudera.org:8080/#/c/8395/4/src/kudu/fs/error_manager.h@80 PS4, Line 80: > Hmm. If err_handler is a closure or a std::function then no, this will not Ah, I see. Yeah, maybe putting it in util/status.h was the right call then for clarity, since it follows similar calls (e.g. RETURN_NOT_OK_RET). Also maybe renaming 'err_handler' to 'on_error' helps there too. Sample usage: RETURN_NOT_OK_CALL(s, error_manager->RunErrorCallback()); or in your example: RETURN_NOT_OK_CALL(s, f()); -- To view, visit http://gerrit.cloudera.org:8080/8395 To unsubscribe, visit http://gerrit.cloudera.org:8080/settings Gerrit-Project: kudu Gerrit-Branch: master Gerrit-MessageType: comment Gerrit-Change-Id: Ie61c408a0b4424f933f40a31147568c2f906be0e Gerrit-Change-Number: 8395 Gerrit-PatchSet: 5 Gerrit-Owner: Andrew Wong <[email protected]> Gerrit-Reviewer: Adar Dembo <[email protected]> Gerrit-Reviewer: Andrew Wong <[email protected]> Gerrit-Reviewer: Kudu Jenkins Gerrit-Reviewer: Mike Percy <[email protected]> Gerrit-Reviewer: Tidy Bot Gerrit-Reviewer: Todd Lipcon <[email protected]> Gerrit-Comment-Date: Mon, 13 Nov 2017 23:56:56 +0000 Gerrit-HasComments: Yes
