Bug#768141: geotiff-bin: fails to upgrade from 'wheezy' - trying to overwrite /usr/share/man/man1/listgeo.1.gz

2014-11-05 Thread Andreas Beckmann
Package: geotiff-bin Version: 1.4.0-4 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'wheezy'. It installed fine in 'wheezy', then the upgrade to 'jessie' fails because it tries to overwrite other

Bug#768216: libgeographic-dev: fails to upgrade from 'wheezy' - trying to overwrite /usr/include/GeographicLib/TransverseMercatorExact.hpp

2014-11-05 Thread Andreas Beckmann
Package: libgeographic-dev Version: 1.37-2 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'wheezy'. It installed fine in 'wheezy', then the upgrade to 'jessie' fails because it tries to overwrite

Bug#656103: libnetcdf7: fails to upgrade from 'sid' - trying to overwrite ...

2012-02-05 Thread Andreas Beckmann
Followup-For: Bug #656103 Hi, during a test with piuparts I noticed your package fails to upgrade from 'sid' to 'experimental'. It installed fine in 'sid', then the upgrade to 'experimental' fails because it tries to overwrite other packages files without declaring a replaces relation. See

Bug#677403: libgdal1: Please add Breaks: libgdal1-1.6.0

2012-06-13 Thread Andreas Beckmann
Package: libgdal1 Version: 1.9.0-3 Severity: important User: debian...@lists.debian.org Usertags: piuparts Hi, while doing piuparts tests I noticed a strange upgrade failure in the qgis-plugin-grass package because apt-get decided to remove this package instead of some obsolete libraries. Log

Bug#667599: dolfin-dev: fails to upgrade from squeeze - apt does not find an upgrade path

2013-02-25 Thread Andreas Beckmann
) instead of installing libjpeg8-dev/wheezy and removing +libjpeg62-dev. Versioned Breaks/Conflicts did not achieve this, causing +the hdf5 stack not being upgraded in some cases. + + -- Andreas Beckmann a...@debian.org Mon, 25 Feb 2013 11:26:57 +0100 + hdf5 (1.8.8-9) unstable; urgency=low

Bug#667599: dolfin-dev: fails to upgrade from squeeze - apt does not find an upgrade path

2013-02-27 Thread Andreas Beckmann
On 2013-02-27 09:46, Ana Guerrero wrote: Bad news, it doesn't fully work. A couple of cases: A) Minimal installation of Squeeze (actually a cowbuilder instance) where it's installed libhdf5-serial-1.8.4 and libhdf5-serial-dev. After the upgrade to wheezy, libhdf5-7 from Wheezy is installed

Bug#667526: hdf5: apt does not find an upgrade path from squeeze

2013-03-17 Thread Andreas Beckmann
On 2013-03-17 22:54, Michael Gilbert wrote: On Sun, Mar 17, 2013 at 5:48 PM, Sylvestre Ledru wrote: On 17/03/2013 21:12, Michael Gilbert wrote: Is there any reason not to apply Andreas' patch to fix this now? Yes, see message #49: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=667526#49 I

Bug#704601: unblock: hdf5/1.8.8-9.1

2013-04-03 Thread Andreas Beckmann
. + + -- Andreas Beckmann a...@debian.org Mon, 25 Feb 2013 11:26:57 +0100 + hdf5 (1.8.8-9) unstable; urgency=low * Force the dependency on the serpack for hdf5-tools hdf5-helpers. diff -Nru hdf5-1.8.8/debian/control hdf5-1.8.8/debian/control --- hdf5-1.8.8/debian/control 2012-03-08 11:18

Bug#723979: libmapserver-6.2.1{, -dev}: transitional packages uninstallable

2013-09-21 Thread Andreas Beckmann
Package: libmapserver-6.2.1,libmapserver-6.2.1-dev Version: 6.4.0-1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package is no longer installable in sid: Package: libmapserver-6.2.1 Version: 6.4.0-1 Depends: libmapserver1

Bug#723980: libosgearth1: transitional package for shared library

2013-09-21 Thread Andreas Beckmann
Package: libosgearth1 Version: 2.4.0+dfsg-4 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package is no longer installable in sid: Package: libosgearth1 Source: osgearth Version: 2.4.0+dfsg-4 Depends: libosgearth2,

Bug#723979: libmapserver-6.2.1{, -dev}: transitional packages uninstallable

2013-09-21 Thread Andreas Beckmann
On 2013-09-22 01:30, Sebastiaan Couwenberg wrote: But do you really need transitional packages for a shared library? From changelog and bugs it looked like it could be the right thing for libmapserver* (I didn't look at the package at all): moving from an unstable API (with hopefully very strict

Bug#734781: libhdf5-cpp-7: fails to upgrade from 'sid' - trying to overwrite /usr/lib/x86_64-linux-gnu/libhdf5_cpp.so.7

2014-01-09 Thread Andreas Beckmann
Package: libhdf5-cpp-7 Version: 1.8.12-4 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Control: affects -1 + libhdf5-dev Hi, during a test with piuparts I noticed your package fails to upgrade from 'sid' to 'experimental'. It installed fine in 'sid', then the upgrade to

Bug#734905: thuban-doc: fails to upgrade from 'wheezy' - trying to overwrite /usr/share/doc-base/thuban

2014-01-10 Thread Andreas Beckmann
Package: thuban-doc Version: 1.2.2-4 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'wheezy'. It installed fine in 'wheezy', then the upgrade to 'jessie' fails because it tries to overwrite other

Bug#732762: nmu: libgdal-grass_1.9.0-1

2014-01-25 Thread Andreas Beckmann
close 732762 1.10.1-1 thanks On 2013-10-22 14:04, Andreas Beckmann wrote: nmu libgdal-grass_1.9.0-1 . ALL . -m Rebuild against grass 6.4.3 dw libgdal-grass_1.9.0-1 . ia64 . -m grass-dev (= 6.4.3) There was a maintainer upload of a new upstream release: 1.10.1-1 that has been built successfully

Bug#738117: qgis: modifies shipped files: /usr/share/qgis/resources/srs.db

2014-02-07 Thread Andreas Beckmann
Package: qgis Version: 2.0.1-1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package modifies shipped files. If this file gets updated automatically (e.g. via triggers) it must not be shipped but handled solely by the

Bug#738273: qgis-providers-common: fails to install, should use triggers for crssync

2014-02-08 Thread Andreas Beckmann
Package: qgis-providers-common Version: 2.0.1-1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package failed to install. As per definition of the release team this makes the package too buggy for a release, thus the severity.

Bug#738273: qgis-providers-common: fails to install, should use triggers for crssync

2014-02-09 Thread Andreas Beckmann
On 2014-02-09 22:52, Sebastiaan Couwenberg wrote: When I upgrade the the qgis 2.0.1-1 packages currently in unstable to 2.0.1-2 from my local repo the triggers are never run. I'll take a look. Is the debdiff you sent also already in git somewhere? That would make it easier for me to experiment.

Bug#738273: qgis-providers-common: fails to install, should use triggers for crssync

2014-02-10 Thread Andreas Beckmann
be an option, then we'll No need to, and if the directory is rather dynamic, not a good idea. Andreas From a11190096054caba491be58c0128029a9b7fea73 Mon Sep 17 00:00:00 2001 From: Andreas Beckmann a...@debian.org Date: Mon, 10 Feb 2014 12:35:03 +0100 Subject: [PATCH] simplify trigger --- debian/qgis

Bug#740327: libapache2-mod-mapcache: unowned directory after purge: /var/cache/mapcache/

2014-02-28 Thread Andreas Beckmann
Package: libapache2-mod-mapcache Version: 1.2.1-1 Severity: important User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package left unowned directories on the system after purge, which is a violation of policy 6.8:

Bug#775245: routino-www: unowned files after purge (policy 6.8, 10.8): /etc/apache2/conf-available/routino-www.conf

2015-01-12 Thread Andreas Beckmann
Package: routino-www Version: 2.7.2-3 Severity: important User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package left unowned files on the system after purge, which is a violation of policy 6.8 (or 10.8):

Bug#779933: python-qgis: fails to install, trying to overwrite other packages files: /usr/lib/python2.7/dist-packages/pyspatialite/dump.py

2015-03-06 Thread Andreas Beckmann
Package: python-qgis Version: 2.8.1+dfsg1-1~exp1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package failed to install because it tries to overwrite other packages files without declaring a Breaks+Replaces relation. See

Bug#782715: geographiclib-doc: fails to upgrade from 'sid' - trying to overwrite /usr/share/doc/geographiclib/html/classGeographicLib_1_1Accumulator-members.html

2015-04-16 Thread Andreas Beckmann
Package: geographiclib-doc Version: 1.41-1~exp1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'sid' to 'experimental'. It installed fine in 'sid', then the upgrade to 'experimental' fails because

Bug#788463: rasterio: /usr/bin/rio already used by the rio package

2015-06-11 Thread Andreas Beckmann
Package: rasterio Version: 0.15.1-1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package failed to install because it tries to overwrite other packages files: From the attached log (scroll to the bottom...): Selecting

Bug#788464: libnetcdf-dev: fails to upgrade from 'sid' - trying to overwrite /usr/bin/nc-config

2015-06-11 Thread Andreas Beckmann
Package: libnetcdf-dev Version: 1:4.3.3.1+ds-1~exp1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'sid' to 'experimental'. It installed fine in 'sid', then the upgrade to 'experimental' fails

Bug#790524: src:gmt: takes over files from several unrelated packages (was: Re: gmt: libgenome-perl in sid already provides /usr/bin/gmt)

2015-06-29 Thread Andreas Beckmann
Followup-For: Bug #790524 Control: retitle -1 src:gmt: takes over files from several unrelated packages In addition to libgenome-perl gmt tries to take over files from several more packages: * libgenome-perl Filelist libgenome-perl vs. gmt: usr/bin/gmt Filelist libgenome-perl vs.

Bug#790521: gmt-common: fails to upgrade from 'sid' - trying to overwrite /usr/share/gmt/pslib/ISO-8859-7.ps

2015-06-29 Thread Andreas Beckmann
Package: gmt-common Version: 5.1.2+dfsg1-1~exp4 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'sid' to 'experimental'. It installed fine in 'sid', then the upgrade to 'experimental' fails because

Bug#790524: gmt: libgenome-perl in sid already provides /usr/bin/gmt

2015-06-29 Thread Andreas Beckmann
Package: gmt Version: 5.1.2+dfsg1-1~exp4 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'sid' to 'experimental'. It installed fine in 'sid', then the upgrade to 'experimental' fails because it

Bug#793859: routino-www: fails to purge: You must invoke apache2-maintscript-helper with an unmodified environment when sourcing it

2015-07-28 Thread Andreas Beckmann
Package: routino-www Version: 2.7.3-2 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package failed to purge. According to policy 7.2 you cannot rely on the depends being available during purge, only the essential packages are

Bug#792103: rasterlite2-bin: fails to upgrade from 'sid' - trying to overwrite /usr/share/man/man1/spatialite.1.gz

2015-07-11 Thread Andreas Beckmann
Package: rasterlite2-bin Version: 1.0.0~rc0+devel1-1~exp1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'sid' to 'experimental'. It installed fine in 'sid', then the upgrade to 'experimental'

Bug#790524: src:gmt: takes over files from several unrelated packages

2015-07-09 Thread Andreas Beckmann
[ dropped all Cc: ] Hi Bas, thanks for looking into these issues. On 2015-07-03 22:11, Sebastiaan Couwenberg wrote: * libgenome-perl Solved :-) * libpsl-dev To resolve the conflict I'm considering renaming the GMT libpsl to libgmt-psl. Sounds reasonable, temporary Conflicts is fine. I was

Bug#790524: src:gmt: takes over files from several unrelated packages

2015-07-10 Thread Andreas Beckmann
On 2015-07-09 23:25, Sebastiaan Couwenberg wrote: The GMT 4 packaging also appended 'gmt' to the man page sections, I've reintroduced this in the ~exp7 revision that was just uploaded. ACK. I think that should do. If you add some more B+R: Selecting previously unselected package

Bug#790524: src:gmt: takes over files from several unrelated packages

2015-07-10 Thread Andreas Beckmann
On 2015-07-10 16:40, Sebastiaan Couwenberg wrote: gmt-manpages can probably be RM'ed from unstable. The auto decruft should take of that when the gmt packages are uploaded to unstable IIRC. No, since gmt-manpages is a separate source package and you are not taking over the gmt-manpages

Bug#798452: osrm: unowned directory after purge: /var/{lib, log}/osrm/

2015-09-09 Thread Andreas Beckmann
Package: osrm Version: 4.7.1-1 Severity: important User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package left unowned directories on the system after purge, which is a violation of policy 6.8:

Bug#813066: proj-rdnap: FTBFS due to testsuite failures

2016-01-28 Thread Andreas Beckmann
Source: proj-rdnap Version: 2008-4 Severity: serious Justification: fails to build from source Hi, your package FTBFS in sid and stretch: [...] dh build dh_testdir dh_update_autotools_config dh_auto_configure dh_auto_build debian/rules override_dh_auto_test make[1]: Entering

Bug#824756: libhdf4-alt-dev: fails to upgrade from 'sid' - trying to overwrite /usr/include/hdf/H4api_adpt.h

2016-05-19 Thread Andreas Beckmann
Package: libhdf4-alt-dev Version: 4.2.11-1~exp1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'sid' to 'experimental'. It installed fine in 'sid', then the upgrade to 'experimental' fails because

Bug#837294: postgresql-9.5-postgis-2.3-scripts: fails to upgrade from 'sid' - trying to overwrite /usr/share/postgresql/9.5/extension/address_standardizer.control

2016-09-10 Thread Andreas Beckmann
Package: postgresql-9.5-postgis-2.3-scripts Version: 2.3.0~beta1+dfsg-1~exp1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'sid' to 'experimental'. It installed fine in 'sid', then the upgrade to

Bug#836993: qgis: fails to upgrade from 'jessie': dpkg-divert: error: rename involves overwriting `/usr/bin/qgis'

2016-09-10 Thread Andreas Beckmann
Followup-For: Bug #836993 Control: found -1 2.14.6+dfsg-2 Control: affects -1 + qgis-plugin-grass Hi Bas, looks like you are doing a more complicated diversion transition ... Preparing to unpack .../qgis_2.14.6+dfsg-2_amd64.deb ... Unpacking qgis (2.14.6+dfsg-2) over (2.4.0-1+b1) ...

Bug#837354: proj: FTBFS on kfreebsd

2016-09-10 Thread Andreas Beckmann
Source: proj Version: 4.9.3-1 Severity: important Hi, proj FTBFS on kfreebsd, but it built there up to version 4.9.2-2: https://buildd.debian.org/status/fetch.php?pkg=proj=kfreebsd-amd64=4.9.3-1=1472926319 https://buildd.debian.org/status/fetch.php?pkg=proj=kfreebsd-i386=4.9.3-1=1472926275

Bug#837354: proj: FTBFS on kfreebsd

2016-09-10 Thread Andreas Beckmann
On 2016-09-10 22:54, Sebastiaan Couwenberg wrote: > On 09/10/2016 10:42 PM, Andreas Beckmann wrote: >> proj FTBFS on kfreebsd, but it built there up to version 4.9.2-2: > > The Java/ant combination is broken on kFreeBSD, that's not something we > can fix in proj. Is there

Bug#836993: qgis: fails to upgrade from 'jessie': dpkg-divert: error: rename involves overwriting `/usr/bin/qgis'

2016-09-17 Thread Andreas Beckmann
Followup-For: Bug #836993 Control: found -1 2.14.6+dfsg-3 Hi, still not completely resolved, I'll try to find some time to look there myself. Preparing to unpack .../qgis_2.14.6+dfsg-3_amd64.deb ... Unpacking qgis (2.14.6+dfsg-3) over (2.4.0-1+b1) ... dpkg: error processing archive

Bug#843352: python-pyorbital-doc: fails to upgrade from 'testing' - trying to overwrite /usr/share/doc-base/pyorbital

2016-11-06 Thread Andreas Beckmann
Package: python-pyorbital-doc Version: 1.1.0-1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'testing'. It installed fine in 'testing', then the upgrade to 'sid' fails because it tries to

Bug#847753: sfcgal: FTBFS on mips, mipsel: out of memory

2016-12-11 Thread Andreas Beckmann
Source: sfcgal Version: 1.3.0-4 Severity: serious Justification: fails to build from source (but built successfully in the past) Hi, the boost 1.62 binNMU failed on mips and mipsel because g++ ran out of memory: https://buildd.debian.org/status/fetch.php?pkg=sfcgal=mips=1.3.0-4%2Bb2=1480467714

Bug#847341: tinyows: missing Build-Depends: libfl-dev

2016-12-07 Thread Andreas Beckmann
Source: tinyows Version: 1.1.1-3 Severity: serious Justification: fails to build from source flex has dropped its dependency on libfl-dev, so this is no longer pulled in transitively and needs to be added to the package itself. Andreas ___

Bug#859918: libgdal20: please add Breaks: libgdal1h

2017-04-09 Thread Andreas Beckmann
Package: libgdal20 Version: 2.1.2+dfsg-3 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Control: affects -1 + libosgearth-dev Hi, during a test with piuparts I noticed at least one upgrade path from jessie to stretch not working properly because apt preferred to keep some

Bug#861303: hdf4-tools: unhandled symlink to directory conversion: /usr/share/doc/PACKAGE

2017-04-27 Thread Andreas Beckmann
Package: hdf4-tools Version: 4.2.12-2 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, an upgrade test with piuparts revealed that your package installs files over existing symlinks and possibly overwrites files owned by other packages. This usually means an old version

Bug#861303: hdf4-tools: unhandled symlink to directory conversion: /usr/share/doc/PACKAGE

2017-04-27 Thread Andreas Beckmann
On 2017-04-27 11:59, Sebastiaan Couwenberg wrote: > Since we cannot fix the squeeze version of the package, adding the and that also wouldn't help long grown systems that are already past squeeze ... > following hdf4-tools.maintscript should fix the upgrade in the stretch > package: > >

Bug#871231: doris: FTBFS with GCC-7: error: ISO C++ forbids comparison between pointer and integer

2017-08-06 Thread Andreas Beckmann
Source: doris Version: 4.06~beta2+dfsg-3 Severity: serious Tags: sid buster User: debian-...@lists.debian.org Usertags: ftbfs-gcc-7 eztrace-contrib FTBFS since GCC-7 was made the default compiler: [...] g++ -Wdate-time -D_FORTIFY_SOURCE=2 -g -O2 -fdebug-prefix-map=/build/doris-4.06~beta2+dfsg=.

Bug#863885: libterralib: superfluous Conflicts/Replaces on libterralib3 cause problems on upgrades to stretch

2017-06-01 Thread Andreas Beckmann
Package: libterralib Version: 4.3.0+dfsg.1-2 Severity: serious Tags: jessie User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed upgrade problems from jessie to stretch that can be attributed to libterralib in jessie. libterralib/jessie has (unversioned)

Bug#863885: libterralib: superfluous Conflicts/Replaces on libterralib3 cause problems on upgrades to stretch

2017-06-05 Thread Andreas Beckmann
Followup-For: Bug #863885 Control: tag -1 patch Hi, I just filed a jessie-pu request with the attached patch. I plan to NMU libterralib for jessie to get this fixed in the next point release. Andreas >From dc64a1dbcc9aaa2b3927fd4883e52ad7560b6e52 Mon Sep 17 00:00:00 2001 From: Andreas Beckm

Bug#875811: postgresql-9.6-postgis-2.4-scripts: fails to upgrade from 'sid' - trying to overwrite /usr/share/postgresql/9.6/extension/address_standardizer.control

2017-09-14 Thread Andreas Beckmann
Package: postgresql-9.6-postgis-2.4-scripts Version: 2.4.0~beta1+dfsg-1~exp1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'sid' to 'experimental'. It installed fine in 'sid', then the upgrade to

Bug#876700: python3-pysal: fails to install: Sorry: TabError: inconsistent use of tabs and spaces in indentation (iwls.py, line 56)

2017-09-24 Thread Andreas Beckmann
Package: python3-pysal Version: 1.14.2-1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package failed to install. As per definition of the release team this makes the package too buggy for a release, thus the severity. >From

Bug#892699: doris: switch B-D to libepr-api-dev

2018-03-11 Thread Andreas Beckmann
Source: doris Version: 5.0.3~beta+dfsg-3 Severity: serious Justification: fails to build from source Hi, the transitional package libepr-api2-dev has been removed, please update your Build-Depends to use libepr-api-dev instead. Andreas ___

Bug#891514: python-epr-doc: missing Breaks+Replaces: python-epr (<< 0.9.3-4~)

2018-02-26 Thread Andreas Beckmann
Package: python-epr-doc Version: 0.9.3-4 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'stable'. It installed fine in 'stable', then the upgrade to 'sid' fails because it tries to overwrite other