2 things:
1) If you still have the old setup:
  Try stopping server, deploying your stuff to it, starting server.
  I've had issues with redeploying at runtime (hot deploy) with Tomcat
(which is what Glassfish is based on).  This is where Jeremy's advice to run
Jetty is a good idea.

2) Make sure that you refresh the form in your web browser before you try to
enter data and submit.  Wicket needs to do stuff to that form before you can
submit it and if you keep same browser open between deployments, you are
sending data back to wicket that it knows nothing about, so it blows up with

The fact that you don't get serialization errors in the log (if it wasn't
serialized) is b/c it didn't get that far yet, so problems are elsewhere.

Hope this helps,
- Alex. 

-----Original Message-----
From: Николай Кучумов [mailto:kuchum...@gmail.com] 
Sent: Saturday, November 14, 2009 9:33 AM
To: users@wicket.apache.org
Subject: Re: CompoundPropertyModel

Hi, Jeremy.
No, the log contained only this error...
But to be honest, although it didn't fix the error, your advice is still
valuable, because not all of the classes were Serializable.
And you know what?
I think I'll reinstall my application server.
I used Glassfish 2 before, and this time I tried Glassfish 3, but it
appeared to be a bitch...
It hangs oftenly and operates strangely...
So maybe it somehow messes with the sessions...
I'll install Glassfish 2 back then, when I have more time for this (maybe
tomorrow), and then I'll post the results here.
Thanks for your reply.

On Sat, Nov 14, 2009 at 5:11 PM, Jeremy Thomerson <jer...@wickettraining.com
> wrote:

> Do both Person and Credentials (and everything else Person holds on to)
> implement Serializable?
> Watch the logs to see if there are serialization errors.  It's a problem
> the page not being in the session - which means it either didn't make it
> there or the session is somehow gone.
> --
> Jeremy Thomerson
> http://www.wickettraining.com
> On Sat, Nov 14, 2009 at 7:26 AM, Николай Кучумов <kuchum...@gmail.com
> >wrote:
> > Hello.
> > I have a "Person" class, describing a person, which has a member
> > "credentials" of type "Credentials" (username/password).
> > I tried to make a registration page in this way:
> >
> > Page
> > {
> >    super();
> >
> >    Person person = [create a person with empty credentials];
> >
> >    Form form = new Form("form", new CompoundPropertyModel(person));
> >
> >    add(form);
> >
> >    form.add(new TextField("familyName"));
> >    form.add(new TextField("givenName"));
> >
> >    form.add(new TextField("credentials.userName"));
> >    form.add(new TextField("credentials.passWord"));
> >
> >    // also add a submit button
> > }
> >
> > And now when I push the "Submit" button, it outputs this error:
> >
> > org.apache.wicket.protocol.http.PageExpiredException: Cannot find the
> > rendered page in session [pagemap=null,componentPath=0,versionNumber=0]
> >
> > I like the idea of compound object model, and I wouldn't like to deprive
> > myself from using it just because of this strange error...
> > Can you give me a hint on what have I done wrong in the code above?
> >

To unsubscribe, e-mail: users-unsubscr...@wicket.apache.org
For additional commands, e-mail: users-h...@wicket.apache.org

Reply via email to