John Simpson wrote:
> On 2006-04-15, at 1917, Rick Widmer wrote:
>> Robin Bowes wrote:
>>> What is the problem you are trying to solve?
>> No real problem, just something I consider wasteful of resources.  For
>> example, if all you are doing is rebuilding a validrcptto database
>> currently you are doing it three times every time you add a domain. 
>> Two of them are instantly thrown away as soon as they finish.
> actually, i'm not- but you do have a point. whoever writes an "onchange"
> script does need to worry about this issue- but i don't think it's right
> to give up the flexibility in order to not have to write proper
> "onchange" scripts.

I agree with John.

>>> Why is this not add_valias, del_valias? (to make it the same as the
>>> user/domain hooks) ?
>> I don't know.  John?
> the idea was that the names were are all the same as vpopmaild commands.
> however, these functions don't exist in vpopmaild, so i used the names
> of the actual functions within the vpopmail source code.
> would it be better to use the vpopmail function names for all of the
> notifications, so that they are all consistent? if so, now is the time
> to make the decision, since nobody (as far as i know) has written any
> onchange scripts which would look for specific strings.

I don't relaly care, as long as they're consistent, i.e. either add_user
or user_add.


Reply via email to