Udo Richter wrote:
> Hi list,
> I've finished a third version of the shutdown rewrite. Again there are
> two patches available, one for VDR 1.5.0, and one with slight changes
> for 1.4.x.
I would suggest to rename NextWakeupEvent() to WakeupTime(), because
there isn't really an "event" involved, and the word "event is generally
used in a different context (for EPG events). Plus, the individual
plugin only has a single wake-up time, so there's no need for "Next".
Accordingly GetNextWakeupEventPlugin() should be renamed to
GetNextWakeupPlugin(). Here the "Next" makes sense, because the
function returns the plugin with the earliest wake-up time. The
"Time" part could be dropped because the function returns a cPlugin*
and there is no time involved.
vdr mailing list