Hi Daniel,

On Tuesday 27 February 2007 19:54:55 Daniel Drake wrote:
> Marcus D. Hanwell wrote:
> >  * Starting eth1
> >  *   Configuring wireless network for eth1
> > Error for wireless request "Set Frequency" (8B04) :
> >     SET failed on device eth1 ; Operation not permitted.
>
> Is this halting the entire process?

It just dies and gives up at this point.
>
> Presumably you set a channel in your networking configuration. zd1211rw
> (and many other wireless drivers) rejects this, as in managed mode,
> scanning is used to find the channel (it's not something that the user
> should have control over).

I didn't set the frequency, I had actually assumed it was the driver trying to 
set its own frequency to match that of the AP. Not sure where the frequency 
request came from then - I just set the essid and key for it. I was trying to 
use simple WEP.
>
> To start with, you should just start by working on the command line
> without any init scripts.

Sorry, I am not really an expert with the command line tools for wireless 
stuff just yet. Scanning for access points with iwlist eth1 scan works 
without any problems but I can't seem to associate with an access point.
>
> Run iwevent in one console to keep track of status. Then in another
> console run:
>
> ifconfig eth1 up
> iwconfig eth1 essid foo key bar
>
> If association succeeds (watch the iwevent window), run: dhcpcd eth1

Association kept failing everytime I tried this. I have used this access point 
with my atheros based miniPCI card using the madwifi-ng drivers and the same 
set up. Here is what iwevent gave me,

20:03:36.971946   eth1     Set ESSID:"cryos"
20:03:36.972410   eth1     Set Encryption key:****-****-****-****-****-****-**
20:03:36.972435   eth1     Set Encryption key:on   Security mode:open
20:03:40.358455   eth1     Scan request completed
20:03:40.373287   eth1     Custom driver event:authenticated
20:03:45.381628   eth1     Custom driver event:associating timed out
>
> > Let me know if there is anymore I can do to help get this adapter working
> > - it seems to be very close already and is bundled with ZyXEL routers
> > right now.
>
> If it is new it may be based on the AL2230S radio rather than the
> AL2230. zd1211rw currently doesn't support AL2230S, and also has a bug
> where it detects it as AL2230 (and doesn't really work as it should).
> This may explain some of the problems you are seeing.
>
> To confirm whether you have an AL2230 or AL2230S, try the vendor driver:
> http://zd1211.ath.cx/wiki/VendorDriver
>
> And use this procedure to check the RF type:
> http://zd1211.ath.cx/wiki/RfTypes#HowdoIfindoutwhichRFispresentinmydevice
>
> I will have my own AL2230S within the next few days and will then solve
> these issues.

I couldn't get the driver to compile, but just noticed the patch for 2.6.20 
kernels... I don't have time tonight but I will try to take another look this 
weekend. Upon insertion I get the following output if it helps at all.

usb 1-6: new high speed USB device using ehci_hcd and address 4
usb 1-6: configuration #1 chosen from 1 choice
usb 1-6: firmware version 0x4330 and device bootcode version 0x4810 differ
zd1211rw 1-6:1.0: firmware version 4605
zd1211rw 1-6:1.0: zd1211 chip 0586:3410 v4810 high 00-13-49 AL2230_RF pa0 g---
zd1211rw 1-6:1.0: eth1

Let me know if it would be useful to work on this further. To be honest I was 
more interested in whether this device worked as I don't really need it too 
much just yet. I can turn WEP off on that access point if it helps, I also 
have my real access point using WPA2 which I could test if this gets working 
later but I didn't want to complicate it too much just yet.

Thanks for getting back to me. Hope life in the States is treating you well!

Marcus

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys-and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Zd1211-devs mailing list - http://zd1211.ath.cx/
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/zd1211-devs

Reply via email to