I do not have s10u10 but in s10u9 zfs get does have aclmode
but in s11x(express) zfs get does not have aclmode any more, there was big discussion and seems that illumos has resurrect aclmode
On 9/13/2011 8:21 AM, Peter Tribble wrote:
On Tue, Sep 13, 2011 at 1:50 AM, Paul B. Henson<hen...@acm.org>  wrote:
I recently saw a message posted to the sunmanagers list complaining
about installing a kernel patch and suddenly having his ACL's disappear
completely whenever a chmod occurred. I replied and asked him to check
if the aclmode attribute was gone, as it sounded like the default
discard that was (questionably) implemented in OpenSolaris/Solaris 11.
He confirmed it was, so it looks like the removal of aclmode was
backported to Solaris 10? I don't know exactly what kernel patch he
installed; it doesn't look like update 10 is out yet.
Update 10 has been out for about 3 weeks.

Can somebody in the know confirm whether or not aclmode is gone in
update 10? I didn't think they'd backport such a feature disabling
change to Solaris 10, seems to not line up with the "long term stability
and compatibility" that's supposed to be the benefit there...
I just tried on a U9 and U10 box. On the U10 system, I did a
simple 'chmod g+s' on a directory with an ACL, and wham, the
ACL vanished. Same operation on U9, and the ACL is preserved.

(This doesn't affect me all that much, as ACLs on ZFS have never
really worked right, so anything where the ACL is critical gets stored
on ufs [yuck].)

Also, aclmode is no longer listed in the usage message you see
if you do 'zfs get'.

<<attachment: laotsao.vcf>>

zfs-discuss mailing list

Reply via email to