On Nov 8, 2007, at 6:25 PM, Jim Fulton wrote:
Why not subclass TransactionError?
It didn't before. Should it?
Seems logical, but I'm not looking that closely. :)
How about "zope.transaction"?
Guido recently told me that people in the Python community at large
assume that anything in the Zope namespace is assumed to be Zope
specific, so I'd rather not put it there.
Does it matter? People who are allergic to the name "zope" can
There's a good deal of 3rd-party code that does "import transaction"
Good point. I guess we should leave the package where it is. Note
that then we have a tricky issue with avoiding having the package
installed twice. I guess we should ignore this for now. :/
It'd be no problem to provide the shims.
For more information about ZODB, see the ZODB Wiki:
ZODB-Dev mailing list - ZODB-Dev@zope.org