Dan, I apologize. I'm still learning.
I replayed the whole damn thing and of course it works well and all devices appear in the zone as configured.
I was just confused because looking at /zones/zone-a/dev still doesn't show any of my device files.
You also wanted me to check ZONEPATH/dev which is still quite empty although the files apear in /dev within the zone.
As my little dtrace script shows the earlier implementation of devfsadm -z <zone> in READY state and the devfsadm -Z during the stop of the zone have disappeared.
It has been replaced by a strange mount -o attrdir=ZONEPATH/dev ... I didnt find anything in the man pages, so I guess I have to look into the source ...

Thanks again,


# more /etc/release             
              Solaris Express Developer Edition 9/07 snv_70b X86
           Copyright 2007 Sun Microsystems, Inc.  All Rights Reserved.
                        Use is subject to license terms.
                            Assembled 30 August 2007

# zoneadm -z zone-a list zone-a -v
ID NAME             STATUS     PATH                           BRAND    IP   
 - zone-a           installed  /zones/zone-a                  native   shared

# ls /zones/zone-a/dev/lockstat
/zones/zone-a/dev/lockstat: No such file or directory

# zonecgf -z zone-a 'add device;set match=/dev/lockstat;end'
# zonecgf -z zone-a info
zonename: zone-a
    match: /dev/lockstat

# zoneadm -z zone-a boot
# zoneadm list -cv
  ID NAME             STATUS     PATH                           BRAND    IP   
   0 global           running    /                              native   shared
   1 zone-a           running    /zones/zone-a                  native   shared
   - zone-b           installed  /zones/zone-b                  native   shared


# ls /zones/zone-a/dev
cpu       dtrace    fd        pts       rmt       sad       swap      term      zconsole


# zlogin zone-a ls /dev
arp conslog console cpu crypto cryptoadm dsk dtrace dtremote fd kstat lockstat log logindmux msglog null poll pool ptmx pts random rdsk rmt sad stderr stdin stdout swap ...

# zone_state.d

          TIME         ZONE  ID STATE
     11280.463         1       zone-a SHUTTDING_DOWN
     12282.011 EXIT:   1 init[993]
     12284.484         1       zone-a EMPTY
     12284.697         1       zone-a DOWN
     12357.223         1       zone-a DYING
     12357.312 EXIT:   1 zsched[981]
     12357.397         1       zone-a DEAD
     12364.892         2       zone-a READY

     12377.392 EXEC: mount -o attrdir=/zones/zone-a/dev /dev /zones/zone-a/root/dev

     12391.944 EXEC: mount -o ro,nosub,nodevices /lib /zones/zone-a/root/lib
     12400.040 EXEC: mount -o ro,nosub,nodevices /platform /zones/zone-a/root/platform
     12406.763 EXEC: mount -o ro,nosub,nodevices /sbin /zones/zone-a/root/sbin
     12412.863 EXEC: mount -o ro,nosub,nodevices /usr /zones/zone-a/root/usr
     12448.600         2       zone-a BOOTING
     12449.042         2       zone-a RUNNING
     12453.645 FORK:   2 init[1560]

script done on Wed Oct 03 15:19:25 2007

Dan Price schrieb:
On Tue 02 Oct 2007 at 07:35AM, Konstantin Gremliza wrote:
    Someone earlier stated that this was also broken in SXDE-- as far as
    I know that is *not* the case.  One of the reasons this has been a
    troublesome area is that in Nevada the /dev zones implementation is
    radically different from S10, due to the existence of the "devnames"
    project in Nevada.  Hence the S10 and Nevada code is pretty in this


Before I posted this to [zone-discuss] I tried again on SXDE 09/07, and the
same problem occured.
Adding a device match will not create any device files in ZONEPATH/dev.

Konstantin, we'll go back and retest SXDE 9/07, although at present we
don't have a bug for this problem open against SXDE.  As I said, the
code is basically completely different in that area between SXDE and
S10, so it would have to be a new and different bug.

My desktop is a SPARC box running build 72 (which AFAIK is SXDE 9/07)
and I don't see this there; this is an example of adding, then
removing a pseudo device in a basic test:
  # uname -a 
  SunOS snowdog 5.11 snv_72 sun4u sparc SUNW,A70
  # ls -l /aux/foo/root/dev/lockstat
  /aux/foo/root/dev/lockstat: No such file or directory
  # zonecfg -z foo 'add device; set match=/dev/lockstat; end'
  # zoneadm -z foo reboot
  # ls -l /aux/foo/root/dev/lockstat
  crw-r--r--   1 root     sys       89,  0 Oct  3 02:55 /aux/foo/root/dev/lockstat
  # zonecfg -z foo 'remove device match=/dev/lockstat'
  # zoneadm -z foo reboot
  # ls -l /aux/foo/root/dev/lockstat
  /aux/foo/root/dev/lockstat: No such file or directory

(Please note that I'm not advising that anyone add /dev/lockstat to
their zone; I simply used it as a test case).

Perhaps you could post your SXDE test case?


Daniel Price - Solaris Kernel Engineering - [EMAIL PROTECTED] - blogs.sun.com/dp


zones-discuss mailing list

Reply via email to