On Thu, Apr 15, 2004 at 11:46:27AM +0200, Philipp von Weitershausen wrote:
| >- The packages in "z" can be used for more than just Zope
| | +2
So, here's an idea:
- Move component-architecture packages out of 'zope' into 'ca', and then we don't have the 'zope' vs 'Zope' issue anymore.
I've been using stuff from 'zope' (except 'zope.app') for a win32 app *wink*.
So, what about this:
zope.component zope.interfaces (?) zope.configuration zope.testing zope.schema (soon-to-be-dead?)
- All move to 'ca.*'
Most of this has nothing to do with the component architecture.
"ca" has nothing to do with zope.
- Move down to 'zope'.
This doesn't solve name-conflict the problem. Or maybe I don't understand what you are proposing.
This is pretty rough. Probably there are more stuff that should move to 'ca', and some stuff which should be grouped into packages, so that 'zope' doesn't get excessively broad.
I think the depth vs breadth balence we have now is about right.
-- Jim Fulton mailto:[EMAIL PROTECTED] Python Powered! CTO (540) 361-1714 http://www.python.org Zope Corporation http://www.zope.com http://www.zope.org
Zope-Dev maillist - [EMAIL PROTECTED]
** No cross posts or HTML encoding! **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce