On 14 Jun 2006, at 00:45, Chris McDonough wrote:
On Jun 13, 2006, at 4:13 PM, Florent Guillaume wrote:
Yes but the deprecation has been there for a while, and the third party product developers have been ignoring the warning. Their loss.

You're right. This only because I haven't managed to get off 2.8 on any of my projects, so I just never see these warnings.

The reason I haven't been able to make it off 2.8 is due mostly to other deprecation/feature addition aggressiveness that has taken place in 2.9 and on the HEAD. Us plain old folks just can't keep up.

I really wouldn't at all mind releasing a patched EE if the thing being deprecated was worth deprecating. But IMO this was a bad deprecation, and we should just un-deprecate it.

FWIW I patched EE's trunk on svn.zope.org.

If we don't remove things at some point, there's no point in doing deprecation warnings.

I think the deprecation shouldn't have been done in the first place. This is only about "methods" not about __ac_permissions__ and so on that have warnings in the file.

We can push it back to Zope 2.11... Actually I really don't care, I've patched EE.

Or we can just pretend we never deprecated 'methods', remove the warning, and get on with it; no harm, no foul.

Then the framework never gets cleaned up.


Florent Guillaume, Nuxeo (Paris, France)   Director of R&D
+33 1 40 33 71 59   http://nuxeo.com   [EMAIL PROTECTED]

Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to