On May 30, 2007, at 4:36 PM, Jodok Batlogg wrote:
I don't see how this helps one say that they want to depend on a
minimum version of a major version. That is, how does it prevent
foo >=1.0 <1.999
I'm wondering how Gentoo got *that* right.
you are able to specify dependencies (http://devmanual.gentoo.org/
>=app-misc/foo-1.23 Version 1.23 or later is required.
>app-misc/foo-1.23 A version strictly later than 1.23 is required.
~app-misc/foo-1.23 Version 1.23 (or any 1.23-r*) is required.
=app-misc/foo-1.23 Exactly version 1.23 is required. If at all
possible, use the ~ form to simplify revision bumps.
<=app-misc/foo-1.23 Version 1.23 or older is required.
<app-misc/foo-1.23 A version strictly before 1.23 is required.
How would you say that you want version 1.23 or higher but less than
any version 2?
Jim Fulton mailto:[EMAIL PROTECTED] Python
CTO (540) 361-1714
Zope Corporation http://www.zope.com http://www.zope.org
Zope3-dev mailing list