On 30.05.2007, at 19:23, Jim Fulton wrote:

It's actually worse than that. <2.0 would admit 2.0a1. :) You'd probably need something like < 1.99.

Even if developers remembered, it would be icky to have to spell out something like >=3.4 <=3.99 on everwhere.

Using foo2 essentially embeds the major version in the package name, which doesn't seem so bad to me.

Maybe there is some kind of dependency syntax that reads well that means "I want this major version". Can you think of a syntax that is actually nicer than foo2?

maybe it's a good idea to use the same pattern as other distribution/ packaging systems.

so foo2 or even foo21 is ok if you compare it to the name 'python24' in macports or ubuntu

so that means that any incompatible version results in a new package name, so one could be shure to have a compatible version of deps e.g. using things like zope.interface.20 without any version restrictions.

Zope3-dev mailing list
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com

Reply via email to