Jim Fulton wrote:
> I don't see how this helps one say that they want to depend on a minimum
> version of a major version.  That is, how does it prevent dependencies
> like:
>      foo >=1.0 <1.999
> I'm wondering how Gentoo got *that* right.

With its naming rules, portage can use a wildcard:



Portage also uses 'foo2' as a configuration variable to control
dependencies while keeping the unaltered package names:

  Code Listing 7: Conditionals based on USE-settings
  DEPEND="X? ( >=x11-base/xfree-4.3 )
  mysql? ( >=dev-db/mysql-3.23.49 )
  apache2? ( >=net-www/apache-2 )
  !apache2? ( =net-www/apache-1* )"

Zope3-dev mailing list
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com

Reply via email to