Jim Fulton wrote:
I have no idea about this specific move. If there was a zope.app.error before, then distributions of it should still exist and new distributions should be backward compatible.

zope.error 3.5 is needed by:

  required by zope.app.applicationcontrol 3.4.1.
  required by zope.app.appsetup 3.4.1.
  required by zope.app.publication 3.4.2.

OK. I'm not sure what the issue is here.

The issue is that the packages Martijn mentioned above as well as zope.app.error were in 3.4.x beta mode. That means they were stabilizing.

Yet zope.app.error was split up into zope.error and zope.app.error without releasing a zope.app.error 3.4.0 final first. The split up should have been done entirely in the 3.5.x series, *after* producing stable 3.4.0 releases.

http://worldcookery.com -- Professional Zope documentation and training
Zope3-dev mailing list
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com

Reply via email to