On 2018-02-19 01:22, Marc Gilliatt wrote:
I removed the BackupPC 4.1.3 tarball's file, and I've installed the
backuppc_3.3.1-2ubuntu3_amd64.deb(my previous version) I got from
online. When I ran it I still receive the following message...

update-rc.d: warning: start and stop actions are no longer supported;
falling back to defaults
Job for backuppc.service failed because the control process exited
with error code. See "systemctl status backuppc.service" and
"journalctl -xe" for details.
invoke-rc.d: initscript backuppc, action "start" failed.
‚óŹ backuppc.service - LSB: Launch backuppc server
   Loaded: loaded (/etc/init.d/backuppc; bad; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2018-02-19 09:20:56
GMT; 12ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 6728 ExecStart=/etc/init.d/backuppc start (code=exited,
status=1/FAILURE)

Feb 19 09:20:56 backuppc01 systemd[1]: Starting LSB: Launch backuppc
server...
Feb 19 09:20:56 backuppc01 backuppc[6728]:  * Starting backuppc...
Feb 19 09:20:56 backuppc01 backuppc[6728]: BackupPC cannot be started
because important parameters are missing from config.pl.
Feb 19 09:20:56 backuppc01 backuppc[6728]: If you just upgraded
BackupPC, please update /etc/backuppc/config.pl.
Feb 19 09:20:56 backuppc01 systemd[1]: backuppc.service: Control
process exited, code=exited status=1
Feb 19 09:20:56 backuppc01 systemd[1]: Failed to start LSB: Launch
backuppc server.
Feb 19 09:20:56 backuppc01 systemd[1]: backuppc.service: Unit entered
failed state.
Feb 19 09:20:56 backuppc01 systemd[1]: backuppc.service: Failed with
result 'exit-code'.
dpkg: error processing package backuppc (--configure):
 subprocess installed post-installation script returned error exit
status 1
Errors were encountered while processing:
 backuppc
E: Sub-process /usr/bin/dpkg returned an error code (1)

 I'm not too sure about what I have done wrong?

------------------------

It's worth looking at the config.pl to see what happened. It may be zero length, or missing, or the 3->4 upgrade may have partially worked after all. In any of these cases, you need only restore the config.pl from wherever you saved it, and you should be all set.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
BackupPC-users mailing list
BackupPC-users@lists.sourceforge.net
List:    https://lists.sourceforge.net/lists/listinfo/backuppc-users
Wiki:    http://backuppc.wiki.sourceforge.net
Project: http://backuppc.sourceforge.net/

Reply via email to