On Wed, Aug 12, 2015 at 08:16:12PM -0700, Thomas Mueller wrote:
T> GENERIB differs from GENERIC by eliminating some old devices like SCSI cards 
and ISA EThernet cards, but I add some wi-fi drivers like urtw, urtwn and rsu.
T> Using the main custom kernel, I was able to build an ndis module from the 
WinX64 drivers net8192su.inf, rtl8192su.sys and, but when I tried 
to ifconfig, the device ndis, ndis0, rtl8192su, rtl8192su0, were not recognized.
T> Being in FreeBSD-current amd64, I used 64-bit WinXP (WinX64); there were 
also drivers for Win 32-bit, for 2000, XP, Vista and 7, all offered in both 
32-bit and 64-bit, except Win 2000, 32-bit only.
T> Hiro USB wireless adapter is H50191, their website is .
T> I wonder if I could have missed a firmware file but couldn't find it in the 
directory structure (maybe ?).
T> Thinking I might have used the wrong syntax with ifconfig, I tried again 
with rsu0 instead of ndis0 or other failed attempts, and was successful 
connecting to Internet.

AFAIU, if you got rsu(4) driver in your kernel it will attach to the hardware,
and the ndis(4) driver won't be able to.

Have you tried to used ndis(4) before on an unpatched vanilla FreeBSD?

Totus tuus, Glebius.
_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to