Per I. Mathisen wrote:
> On Mon, 18 Jun 2007, William Allen Simpson wrote:
>> My observation is that the main problem we experienced was trying to 
>> change
>> from tolua++.h to tolua.h.
> 
> No, that was just an amusing side-show. The problem was that tolua++ 
> generated a faulty api_gen.c file.
> 
OK, my order of suggestions was based on the PR#39400 problem with
tolua.  Christian didn't report a problem with lua.  In fact, he indicates
that the his sarge box works with lua (an external lib?)

Maybe we should reverse my suggestion.

1) install the latest lua.  Make sure it works.  Surely the latest lua will
still work with the older tolua!

2) reorganize the tolua tree a little bit to be compiled by "make tools" --
so that cross-compiling works correctly.

3) then, knowing that everything else works, try installing tolua++.  Narrow
the problems to a single point of failure.


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to