Per Inge Mathisen wrote:
> On 6/18/07, William Allen Simpson <[EMAIL PROTECTED]> wrote:
>> 1) install the latest lua.  Make sure it works.  Surely the latest lua will
>> still work with the older tolua!
> 
> No, tolua 5.0 does not work with lua 5.1, unfortunately. And there is
> no more recent version of tolua, hence the use of tolua++, a more up
> to date derivative version.
> 
Ah.  So it has to be tolua first.  According to the documentation, tolua++
will work with both lua 5.0 and 5.1.

OK, we have a plan.

===

Unfortunately, tolua++ doesn't seem to be widely available as an external
package.  It has to be in the source tree.

However, I checked my current favorite platforms (MacPorts, NetBSD pkgsrc,
debian, Ubuntu), and all of them have lua 5.1.2 as packages.  I'm thinking
that maybe the way to go with lua is the same as gettext -- change to a
build option, but allow an up-to-date external library for most folks.

_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to