Although I have been using fvwm as a window manager under gnome for
years (and much appreciating its excellent attributes), suddenly two
days ago (perhaps after altering some permissions in /tmp, trying to get
k3b to work properly, and maybe upgrading about four or five packages) I
found an odd problem when trying to start fvwm in a running

I am using Fedora 7, with the fvwm-2.5.21-4.fc7.1 package that came with
it (wow was I surprised to see fedora now ships fvwm).

When I installed F7 about a month ago everything worked smoothly; all I
had to do was to give the "fvwm -s 0 --replace" command and since I had
created $HOME/.fvwm with my config file in it, everything worked,
metacity was replaced by fvwm and I was swimming again.  Sessions are
saved, and subsequent logins start the gnome-session with fvwm as the
window manager, just as advertised.

Right now, however, the fvwm session has ceased to work; windows (like
xterm or gnome-terminal) are sans title bars and unusable, the
FvwmButtons panel flashes on and then disappears, the gnome panels are
gone, and about all I can do from such a state is to hit
CTRL-ALT-BACKSPACE to get back to my login screen.

However there are ways some things do (or do not) work:

1.  If I delete $HOME/.fvwm (so my config file is gone) then fvwm starts
under the gnome-session, although it complains about not being able to
find a config (or .fvwm2rc) file.  (What does fvwm use for a config in
that case?  I have no idea.)  Of course then I get crummy titlebars
(even over the gnome panels) etc., which I have no idea how to fix.

2.  I don't think my config file is at fault, however, since if I
replace my config file with, say, system.fvwm2rc, or
system.fvwm2rc-sample-1 (samples that are in the fvwm source distro)
it also does NOT work.

3.  I can log on with bare fvwm (no gnome) and that works, and then I can
start a gnome-session after fvwm is working (with my config).  As long as
I don't kill the window from which I started gnome-session I have a
usable system.  Since I don't want the gnome desktop to act as a
barrier to my root window I do the following:

(a) In System-->Preferences-->Personal-->Sessions change the nautilus
from "restart" to "normal" and apply;
(b) issue the command "pkill bonobo";
(c) issue the command "killall nautilus; sleep 2; nautilus --no-desktop &" 

(Maybe there are other ways to accomplish this, but the above works for

But I would like to be able to run fvwm under gnome-session and not the
other way around.  Does anyone have any idea what might be happening?
Is this an EWMH issue?  What could have possibly changed in my system to
have caused this problem?  What should I try?  Has anyone else
experienced this behavior?

    -- Peter

Reply via email to