Here is yet another update, with somewhat positive results.

[I hope this information might be useful to other FVWM
afficianados.]

A summary of my original problem appears (far) below.

It turned out that the PROBLEM lay not with either FVWM or
GNOME, but (perhaps as Myles Green suggested) with Fedora 7.
The situation got worse and worse, and eventually I could not
even boot my system.  (It could be that I became infected by a
virus, but I do not really know.)  Since there were several
other rather annoying features involved with F7, and since a
friend made positive comments regarding Scientific Linux
(https://www.scientificlinux.org/) I managed to download the
ISOS for SL 5.0, back up my files onto an otherwise unused
drive, and installed SL 5.0.

SL 5.0, which is the creation of folks at C.E.R.N. and
Fermilab and is patterned after RHEL 5.0, is very nice, and
updates with yum.  It is perhaps closer to FC6 than F7, but
so far working very well for my system.
Its current kernel is 2.6.18-8.1.8.el5.x86_64,
gnome-session is 2.16.0-6.el5.x86_64, and I had no trouble at
all building FVWM 2.5.21 and installing it, where it is the WM
under GNOME.  [By the way, I used libstroke-0.5.1.tar.gz and
it works fine---I see there's a recent post re libstroke.]

---------------------------
Also by the way, here is a handy trick that could be noted on
FVWM's FAQ page:  After issuing the command fvwm --replace &
(which worked), I found it desireable to get rid of the
gnome/nautilus desktop.  I did not want the dumb gnome icons
and I wanted to be able to display FVWM menus by clicking on
the root window.  After fiddling around I found this to work
for me (following a suggestion on a mailing list):

gconftool-2 --type bool \
--set /apps/nautilus/preferences/show_desktop false
---------------------------

The only other stumbling blocks involved getting the correct
nvidia graphics driver (have to download it from the nvidia
site: NVIDIA-Linux-x86_64-1.0-9742-pkg2.run), getting the
gutenprint epson printer driver to compile so it would find
the correct lib64 libijs.so lib it needed, and enabling X11's
SHAPE extension (put 'Load "extmod"' in the Module section of
xorg.conf) so that xine would work correctly and my FVWM icons
would honor transparency in their images.

But all is solved now and I am swimming again downstream.

[I now have an FVWM config file that I like, with pretty
extensive comments.  I would be happy to forward it to anyone
who wants it.  I also found it helpful to create a pdf file
from the FVWM man page (using enscript to create a PostScript
file, and then ps2pdf to create the pdf).  Then one may use
acroread to view the file, whose excellent search routine can
then be used to find words or phrases---thus supplying a
useful ersatz index to the FVWM man page.]

    -- Peter

==================================================================
On Jul 27, 2007 at  3:52 pm, Peter Scott wrote:
| 
| This is an update on this problem, which to summarize, is the following:
| 
| PROBLEM:
| 
| When I installed F7 about a month ago everything worked smoothly; all I
| had to do was to give the "fvwm -s 0 --replace" command and since I had
| created $HOME/.fvwm with my config file in it, everything worked,
| metacity was replaced by fvwm and I was swimming again.  Sessions are
| saved, and subsequent logins start the gnome-session with fvwm as the
| window manager, just as advertised.
| 
| Right now, however, the fvwm session has ceased to work; windows (like
| xterm or gnome-terminal) are sans title bars and unusable, the
| FvwmButtons panel flashes on and then disappears, the gnome panels are
| gone, and about all I can do from such a state is to hit
| CTRL-ALT-BACKSPACE to get back to my login screen.
| 
| UPDATE:
| 
| I did some trials, and here is what I am finding:
| 
| The system becomes inoperable (in the sense described above) whenever an
| FVWM module is killed.  The most dramatic example is Module FvwmBanner,
| which, when called (either from the FvwmConsole or from a line in a
| config file), does display the FVWM banner, but after the default 3
| seconds, when it dies, the system behaves as above, and I am reduced to
| CTRL-ALT-BACKSPACE to recover.
| 
| This also happens for other modules, like FvwmButtons: when invoked, my
| buttons come up, but when the module is killed, either by issueing the
| KillModule FvwmButtons command from the FvwmConsole, or by using xkill
| from an xterm, the system becomes inoperable.
| 
| Other modules yield the same behavior.
| 
| I am using Fedora 7 with kernel version 2.6.22.1-27.fc7.
| My gnome-session version is 2.18.3-1.fc7.
| 
| This behavior occurs whether or not nautilus is running.
| 
| Any suggestions as to what to try?  Probably one thing to try is to
| revert to an earlier version of GNOME, but could there be an alternative
| solution?  I would hate to see FVWM and GNOME get out of sync, since
| FVWM is far and away the best WM.
| 
| Thanks so much for any help,
| 
|     -- Peter
| 

Reply via email to