This is an update on this problem, which to summarize, is the following:


When I installed F7 about a month ago everything worked smoothly; all I
had to do was to give the "fvwm -s 0 --replace" command and since I had
created $HOME/.fvwm with my config file in it, everything worked,
metacity was replaced by fvwm and I was swimming again.  Sessions are
saved, and subsequent logins start the gnome-session with fvwm as the
window manager, just as advertised.

Right now, however, the fvwm session has ceased to work; windows (like
xterm or gnome-terminal) are sans title bars and unusable, the
FvwmButtons panel flashes on and then disappears, the gnome panels are
gone, and about all I can do from such a state is to hit
CTRL-ALT-BACKSPACE to get back to my login screen.


I did some trials, and here is what I am finding:

The system becomes inoperable (in the sense described above) whenever an
FVWM module is killed.  The most dramatic example is Module FvwmBanner,
which, when called (either from the FvwmConsole or from a line in a
config file), does display the FVWM banner, but after the default 3
seconds, when it dies, the system behaves as above, and I am reduced to

This also happens for other modules, like FvwmButtons: when invoked, my
buttons come up, but when the module is killed, either by issueing the
KillModule FvwmButtons command from the FvwmConsole, or by using xkill
from an xterm, the system becomes inoperable.

Other modules yield the same behavior.

I am using Fedora 7 with kernel version
My gnome-session version is 2.18.3-1.fc7.

This behavior occurs whether or not nautilus is running.

Any suggestions as to what to try?  Probably one thing to try is to
revert to an earlier version of GNOME, but could there be an alternative
solution?  I would hate to see FVWM and GNOME get out of sync, since
FVWM is far and away the best WM.

Thanks so much for any help,

    -- Peter

Reply via email to